DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Installing server on ubuntu


#1

I’ve started to install server on ubuntu and got to step 5.
I got the message: [20:52:46] access denied (socket exception)
Now I seem not to be able to access my desktop version either, it throws up this screen

Any help or advice welcome as I need it tomorrow to do invoices!


#2

Upgrade to the latest version. That will fix this issue.


#3

OK updating Manager through Ubuntu software centre has given me back the desktop version.
I’m following the online instructions to install Server edition but still end up with this screen.

Any suggestions?


#4

I think only administrator can run software which will open port 80.

So first, try mono ManagerServer.exe which will start server on port 8080.

If it works, try to run server as admin using command sudo mono ManagerServer.exe -port 80


#5

OK, I think I’m a bit further on though I don’t really understand the “port” thing. I’m hoping I don’t need to!

I tried your first suggestion and got a screen ending with “HTTP server listening on port 8080”.

I then tried the second suggestion and got this screen.

Perhaps I’m not too clever, but I’ve no idea what to do next. The setup instructions say " Open your web-browser and type IP address of your new server". I don’t know what this is.

Perhaps there should be another set of instructions for really stupid people!


#6

Now open Chrome or Firefox and type localhost:80. That will open Manager


#8

Hi @alim @lubos

OK I did that and it asks for a login. Username seems to be set at “administrator” and the password I don’t know. I thought it might be the password for my computer permissions but that does not work. Apparently I can delete the password by going to /root/.local/share/Manager/password. I tried this but apparently I don’t have the permissions to view the contents of “root”.

I only want to buy the Server version of Manager! I’m losing the will to live here!


#9

Default password is empty. So just hit Login button without entering any password.


#10

Thank you @lubos!

As you can tell I’m not very computer savvy!

Is there a guide somewhere that will tell me how to access this from another computer etc. or do I just access it in the same way with “localhost:80”?

The Manager accounting system is great for small businesses like us, I think my struggle is with Ubuntu.


#11

I now have an additional problem, When I type localhost:80 into the address bar it returns:

This web page is not available.
ERR_CONNECTION_REFUSED

I have two browsers installed, Chrome and Firefox. Both are the same.


#12

Make sure ManagerServer is running.

Follow the instructions here to make ManagerServer autorun after boot.


#13

Thank you. I’ve e-mailed the support address to try to sort this out. I’ve no idea how to write the line with the filepath in it. I’m beginning to suspect that Ubuntu and Manager are just for techie people, not cheesemakers!