Problem installing the server version on my mac

I have installed Manager on my mac, but always get an error " The requested address is not valid in this context (SocketException)"

I’m running Sierra and have tried different versions of “mono”, the latest version, version 4 and 5 (i’d read a post on the forum where these worked for one user).

I’ve tried different ports etc, but no luck.

Does anyone have a clue as to how to fix this ?

PS:- If i do find a solution, i’ll post here.

Did you read this Guide: https://www.manager.io/guides/22451? And did you follow the links in it to reach the instructions for macOS? Did you follow those instructions?

Hi,

Thank you for the reply.

Yes, I followed the insructions exactly, when i get to the stage to start ManagerServer (mono ManagerServer.exe) instead of getting “HTTP Server listening on port 8080” I get the error message (The requested address is not valid in this context (SocketException)) in place of the example on the web page.

I have tried different ports (no difference) and have no firewall enabled on the mac.

I tried running the same download on a Virtual machine (Windows) and it worked fine.

You’re beyond my expertise. Someone else will need to help.

Thank you anyway.

I suspect it’s the way that the “server” makes a http request to localhost or 127.0.0.0, but with not having the source i can only guess.

You have probably got another web service running / listening on port 8080, so when Manager comes along and attempts to start up and use port 8080 it fails. What you have to do is identify what is using port 8080, then shut it down. Try netstat -a | grep -i “listen” to see if something is conflicting or already in play with port 8080. This topic is outside the forum scope. Good luck.

Thank you, but that didn’t show up anything, neither did lsof -nP -i4TCP:8080

How did you go with this?

Can you describe your error a little more clearly, for example:

Where exactly are you getting this error (“requested address is not valid in this context”)?

Is it in the browser itself when trying to load the page?
What is the url you are using to access the page?
What is reported on the command line when you start manager? (ie: mono ManagerServer.exe, please paste the output from the command line)
If there is a port conflict, try running manager on a different port:
mono ManagerServer.exe -p 8083 (with loads of exceptions, you can pretty much use any number here, but just try something between 8081 thru 8888—those numbers themselves (from me) are arbitrary).
When trying to run on a different port, what was the response on the command line?

I don’t float here too often, although may have more time now! But I’m sure we can get you up and running (and I’m just a user too, however, I use Server on a linux install).