DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Emails not being received


#1

When sending ‘sales invoices’ I have always cc’d our own email in so I get a copy to my own inbox when the client does.

We haven’t received a copy of sales invoices to our emails for 4 weeks now and we have had clients also say they aren’t being received.

We have added to safe sender list / white list and also advised our clients to (for no-reply@no-reply.io).

We need urgent help.

NOTE EDIT: have seen that there is now an update so have ticked in email settings to receive a copy to our email rather then adding our email address when sending sales invoice but still not receiving


#2

I don’t see any issue at our end. The system reports emails are being successfully delivered. Perhaps try sending yourself copy to another email address (e.g. Gmail) and see if you start receiving those emails. If you do, then you need to inquire with your current email provider. They might be silently dropping emails from no-reply.io domain.

The best way is to use custom SMTP server. That is not to rely on built-in one. It works but custom SMTP server will work even better.


#3

Thanks Lubos. I’ll send to an external email and see if i still have the same issue. Clients have been saying for a few months they are not receiving and its only of late that I also have stopped receiving. Will keep this thread updated :slight_smile:


#4

Hi again @lubos

have had no luck receiving this same email. Tested sending to an external email and receiving it ok. checked webmail - the email doesn’t reach the server at all. I have contacted my SP (westnet / iinet - grrrr) who say the issue isnt on their end. Doesnt seem to be an issue with my ‘mac mail’ as its not getting to webmail/server.

Any other suggestions?


#5

You don’t mention whether you’re using the built in mailer, or using the custom SMTP server. I strongly recommend using the custom SMTP server, due to the fact that many (if not most) ISPs have policies that make sending email from dynamic IP address blocks problematic. Try setting up the Custom SMTP server with exactly the same credentials as you use in your email client such as Outlook or Thunderbird. If it works with an email client it will work with manager.


#6

Hi @Bazza338

Thanks, that actually worked using SMTP (with SSL selected as well).

The only issue now is i have Send a copy of every email to this address however i am not receiving the email copy. If I cc: that same email address when sending the email to client, then I receive it ok.

Any thoughts on why its not being received when ticking ‘send a copy’ in email settings?

Jen


#7

The only thing I can think of is that you might have a slight misspelling in the email address (for example I’ve accidentally typed a “,” instead of a “.” and wondered why the mail wasn’t working).


#8

Hi again @lubos and @Bazza338

I changed setup to SMTP and this has worked for a while. Have sent out invoices yesterday some have sent and received ok but many again have not sent. Email addreses are 100% correct. SP have done a full investigation and the issue is not their end.

I notice when sending from manager it takes no time to send email where as previously it would take a few seconds to send each one.

I really need some support with this one. @lubos are you able to check back end to see if anything going on?

Thanks in advance


#9

Check spam folder and did your service provider for ‘email’ have the setting of allowing imap smtp?


#10

If Manager did not report an error, then in all likelihood the emails were sent successfully. The host providing the SMTP service should be able to verify that it received all the messages sent by Manager and that they relayed them on to the intended recipient. Are they able to do that? Their log should match the email log in Manager.


#11

@Bazza338 is correct. If there is no error, then Manager got successful reply from custom or built-in SMTP server that email has been sent.

@southside you said you are using custom SMTP server. What does it even mean when they say “full investigation” ? What is their conclusion? Do they see Manager connecting to it and sending email? Can you use different SMTP server? For example www.mailgun.com offers free SMTP server for first 10,000 emails per month. For troubleshooting purposes, you can examine log file.


#12

Still no luck. Not keen on getting 3rd party SMTP server - just throws a 3rd party in to further confuse things.

If i send an email by clicking ‘test settings’ i get it, but real emails - nope. Have tried sending to an external email address and I get them sparodically.

This worked for 3.5 years without issues - now… I can’t use this function.

My service provider is shocking and I am just getting no answers.


#13

This shows the problem is not within Manager.


#14

getting them sparodicaly doesn’t actually prove its the application or the 3rd party. It was once working and now its’ not. Both parties are saying its the other. Not sure where to go from here.


#15

What e-mail address is Manager specifying in the “from” field? Is it your ISP-issued e-mail address, or is it an address within your own domain? If it’s the latter, have you altered the SPF record for your domain to indicate that your ISP’s mail server is allowed to deliver mail on your behalf? Hint: add “include:spf.westnet.com.au” to your existing SPF string.

Do you have a G-mail account to test with? Try sending an e-mail to your G-mail account then look at the headers (while viewing the message on Google’s webmail interface, click the three dots on the far right and choose “show original”). The headers will tell you how Google processed the message with regard to SPF and spam scoring, and the multiple “Received:” lines will show what path the message took.

If you can’t decypher what the headers say, send them to me in a private message through here and I’ll help you out.

I was originally going to say that you shouldn’t expect anyone to consistently receive messages sent through no-reply.io or MailGun as the former resides in Amazon netspace which is widely blocked throughout the world, and the latter is a recognised spam-for-hire service, suffering the same widespread blocking for similar reasons - but you’ve already eliminated that possible cause, and I highly doubt that iiNet’s outbound servers would be blocked by anyone.


#16

thanks @Cognicom. I have been testing to an external email and tests to this one also don’t seem to make it. I believe its the SMTP setup which needs tweaking. If I don’t use an SMTP server - most get through but any addressed to westnet.com, iinet.net.au or aapt email addresses don’t get received. Trying to find something that works for all is the problem. Finally got through to someone at my SP who logged in and assisted with spam filters through a web ‘toolbox’ - this looks like it may have worked! Appreciate your reply, fingers crossed.


#17

Good luck; it can get rather frustrating when everything appears to be running through a “black box.”

Feel free to give me a yell if you encounter further problems though; I’ve (among many other things) been administering mail servers for over two decades, so there aren’t too many tricks that I haven’t learnt.