Email Settings

I cannot set up my email in settings I keep getting this error:

The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.5.1 Authentication Required.

Have you read the guides on email settings - they have examples for the most common email servers?

What email service are you trying to connect to?

3F4D5FF50C73468EAAC4DFC8C25AF68F.png

Sorry, I can’t see the image clearly - it looks like gmail but not sure

If it is, have you followed the steps here Google Gmail

And what version of Manager are you using? the email setup was changed a few versins ago, so make sure you are up to date. It looks like you are on an old version

I use Gmail without any problems (allowing less secure apps)

I also have the same problem. I have followed all the steps that Gmail requires for such settings. It was initially working in a previous version but not this version((19.7.47). @lubos can you please bring back the check box for secure connection, maybe that can be the solution to the problem. Trust me I have done all the setting required in my Gmail account but the problem still persists.

@Daniel_Arthur what error do you get?

Kindly see below the error I get. I have done all the settings that needs to be done at the Gmail side:

This type of error will show if the password for Gmail account is entered incorrectly. The latest version (19.7.59) adds “Show password” checkbox so when entering the password, you can click the checkbox to reveal the password and make sure it’s entered correctly. So try to re-enter the password in the latest version.

@lubos, the checkbox works initially. But, if Email Settings is revisited, the box does not show, the password is not visible, and the only way to see the box again is to re-enter the password. In fact, the behavior makes it look like no password has been entered, although the previous one is still stored. This makes it difficult to troubleshoot a connection, since you cannot see the password setting that failed to authenticate.

Different applications behave differently. Some always hide the password, some optionally show when entering, some allow optionally showing at any time.

The most appropriate probably depends on who else could see the pass word. This is most significant for multiuser installations / server versions. For that case visibility of passwords to all users at any time is probably not ideal.

I concur. But restricting permissions for the Email Settings is the appropriate way to handle this. It doesn’t make sense to add a password visibility option for the purpose of troubleshooting, but then prevent visibility. Anyone who would be allowed access to the Email Settings page should be able to see the password.

Tut, if the email setup page is otherwise protected then showing the password to the restricted audience sound fine.

However I think this is probably a distraction from the real problem though. Most users can enter a password. I think the real problems is:

  • Setting up reliable communication with a SMTP server is beyond many users capabilities
  • Manager avoided this in the past by providing a default email service maintained centrally
  • To enable typical users to connect to an email relay, email clients have found it necessary to provide:
  1. Broad connection options:- to cover almost all email relay requirements
  2. Automatic configuration based on a table of service specific settings. Typically a default simple mode with advanced setting revealed if required. I’m not sure if Thunderbirds configuration portal could be utilized.
  3. Generous error reporting when connections fail together with a list of thing the user needs to check. Such as Google need to reverify account.

In summary Manager will have user issues with email because connecting an email client is not easy nor the focus to email services. When set up fails a bad password is often reported but is typically not actually the problem, so showing it will make little difference.

I beg to differ but this is not the reason because I am very sure I am entering the right password. This problem persists when Gmail system senses that you are connecting to it from an insecure source. Not the password being wrong. So please check the email connection issue again for a solution to this problem of SMTP requiring a secure connection. Thank you.

Have you tried to re-enter your password in the latest version with Show password checkbox on? This would rule out possibility of password being entered incorrectly.

Also, it’s not obvious from your screenshot but do you use custom domain or @gmail.com ?

gmail has extra authentication which you have to disable on the gmail side as per https://www.manager.io/guides/22820 or for Google suite. Changes there by you or google will stop it working. It is designed to required re-authentication intermittently forcing you to re-login to their web interface. Their official reasoning is for security. However if you look at their business model, it also increases the revenue from their product (“free users” screen space and time combined with accurate consumer profiling). So expecting using google services to be easy to use for task which don’t optimize their income is optimistic.

It is possible Manager has a new problem however to track such bugs, a fair amount of detail would be required both on the Manger settings and google protection disabling approach you are using. Also for a Manager problems most people with the same Manager version and same gmail security setting would also be experiencing the issue. Perhaps not obvious initially but should be soon very clear.

Yes I have and the problem persists. With same error message. And yes I am using @gmail.com any further help?

Redo the gmail authorisation as described here https://www.manager.io/guides/22820
Gmail requires it intermittently. Then tell Lubos which option you are using

@Daniel_Arthur are you using 2-factor authentication (2FA) for your Gmail account?

No please.