Email problem after upgrade

Hi @knireis, it looks like the issue is that your system is using TLSv1 instead of TLS1.2. TLSv1 was disabled at postmark 1st Feb this year. see Security upgrades to SMTP sending — action may be required | Postmark.

There is another issue I have found and it’s to do with removing the Username and password. In general, if you use your ISP mail server, you can use port 25 and do not need username and password. However, it seems that the Server version (running in linux) does not like having a blank username and password when using port 25.

If you use port 25 manager will attempt authentication with username and password which it seems to make up.

Here is the settings that caused that result.

I created a new business and it worked using my ISP mail server with no username and password on port 25 UNTIL I entered a username and password.

P.S. I installed a new 18.04 ubuntu WSL on my win 10 and set up Manager Server. I also used Wireshark to capture what is going on.

My isp does not allow port 25 to be used. I don know about Postmark.
I can hardly believe Ubuntu 20.04 will use TLSv1. Maybe Manager uses it?

I did another test on a windows VM and there it works fine, so it seems to be a linux issue.

My experience is with Windows and from the Wireshark capture TLSv1.2 is being used automatically in Windows.

I tried to configure OpenSSL to use minimum protocol of TLSv1.2 but I think we need @lubos to confirm that manager uses OpenSSL.

My ISP also supported port 587 even though they do not advertise it. They also supported TLSv1 so I was able to send email (blank username and password, which is a problem right now unless it is new business and not set to start)

Edit: So it looks like mono is responsible for providing the secure transport layer. I upgraded my mono version to and tried setting export MONO_TLS_PROVIDER=btls but it still insisted on using TLSv1.

No. I don’t use Linux and I don’t use Postmark. Based on @MarkLL’s comments, it looks like this is an issue with your internet provider or setup. It has been a long time since anyone’s email problems turned out to be a Manager bug.

The provider works fine on Win10 and on linux email clients.
It might not be a direct bug but somehow the linux version seems to have an issue with sending mail.

A post was split to a new topic: Password can not be removed from SMTP credentials

The issue with Manager not sending email has been fixed in latest version.

I finally managed to successfully do a new install of Manager Server to version 20.9.89. I opened with ufw ports 25 and 587 among others but the email test times out on both ports. It used to work on port 25 with the previous Server edition that worked with mono. I contacted my ISP but as credentials work on their server they advised to seek support here. Thank you in advance.

See the Guide: Troubleshoot email issues | Manager. Visit all relevant links. If you cannot resolve your problem, provide all information requested in the Guide.

@Tut I have used this and all worked well until the recent upgrade to Manager Server version 20.9.89 Please try yourself with the new Server version as it no longer works, thank you. As mentioned all ports are enabled.
MANAGER-SERVER version 20.9.89
OS: Ubuntu 20.04
Email credentials as working on email account. Tried ports 25 and 587 both gave time out errors when testing.
All relevant SMTP and IMAP ports enabled in ufw

No one else can try your email. You have obscured your SMTP server hostname, so no one can even determine whether your settings look credible.

I followed he instruction “… A screen shot of your Email Settings page (Obscure only personal information. The more information you show, the easier it will be to obtain help.)…” As the servername is the same as I would disclose the personal information that I should not.
As mentioned the email server works well and also worked well with these settings before the Manager Server upgrade.

I cannot see why you consider a domain name to be personal information. But that is your decision.

I agree! However, I follow your instructions and this would disclose email So please highlght for me what other personal information I should blank out as this is the only personal info one could obtain. I also do not see what you could digest from the mailserver info without the account info. Can you please confirm that you tested it yourself with your own Manager-Server installation to ensure that I am not hallucinating that this is a bug introduced with the new version.

Out of curiousity I also trialled the desktop version. The ones before the non Nano version works and version 20.9.3 doesn’t (OSX Catalina)

@eko, there is no requirement to obscure anything. The purpose of the instruction is to allow users to obscure such things as a personal email address to which they are sending copies. Since you are sending your customers and suppliers emails, there seems to be no reason to obscure the domain from which those emails will come.

As I already told you, no one can test your email settings except you.

I don’t know what you are referring to as the “non Nano version.” And I do not understand what v20.9.3 has to do with anything. Are you referring to Mono? If so, Manager was still using Mono in v20.9.3. That changed at v20.9.66.

Sorry I meant Mono. The older Desktop version works and the latest v20.9.89 also does not.

Highly likely a firewall issue.

To troubleshoot,

  1. confirm that you only use ubuntu firewall and your router is open for outgoing traffic;
  2. confirm that you allowed default rule for all outgoing traffic/port? or specifically;
    sudo ufw allow out to any port 587
  3. output ufw status rules here for information;
    sudo ufw status verbose

timeout suggests that ports are being blocked.

Thanks but I already opened these ports in ufw and many more such s the IMAP and POP ports. ufw status confirms the allow on these ports. As it also happens on my OSX- Catalina computer with Manager desktop version v20.9.89 and with firewall and antivirus disabled and the Manager Server v20.9.89 on Ubuntu 20.04, while both worked well before the non Mono versions it would be useful to know 1) do others have same issues since upgrade and 2) if so did they resolve it.

I am asking the questions to troubleshoot because email function works for me on the latest version.

There is no way to know unless they post on the forum. I can only tell you that email timeout or log-on problems have been reported irregularly once or twice per month for years. They have almost always turned out to be user setup problems, even when someone thinks they have changed nothing in a working setup. Often, they are the result of ever-tightening security measures by email providers—sometimes in the face of denials of any changes by the providers, while their web sites reveal exactly the opposite.

Your report of difficult is the only one since the switch to .net Core and deprecation of Mono a few weeks ago. So the rate of reported problems has not increased. If this was a Manager issue, many more of the thousands and thousands of users would be complaining.

Meanwhile, if you were willing to share your provider’s identity, someone might have useful advice.