Cannot update from v20.8.27 to v21.1.55

Manager crashed when I try to upgrade from x20.8.27 to x21.1.55 (Windows 10 64-bit).

(Yes, I’ve been away for a while.)

When I try to install v21.1.55 over v20.8.27 in the usual manner (I’ve also tried deleting the old version before installing the new, with the same results), first I see a new dialog requiring me to install Microsoft Edge Runtime:

  • 1

I don’t use Edge, but I accepted this generous offer:

Then this happens:

  • 3

And then when I try to run Manager, I get this, every time:

  • 4

I’ve successfully deleted the Manager program directory and restored the old directory from my nightly backup. Manager v20.8.27 still works, thankfully.

How do I update to v21.1.55?

Thanks.

I just tried again, this time clicking the “Fallback to IE” button on the first dialog box:

  • 1

Manager v21.1.55 installed this time (after I dismissed a dialog box saying “WebView2 was not installed”). Every time I start Manager now, it again asks me to install WebView2 and I have to click “Fallback to IE” and dismiss the second dialog box.

Is it safe to continue to use Manager v21.1.55 in “Fallback to IE” mode, or is there risk of data loss or future failure?

Webview is required if you want to use copy to clipboard for batch update for the Desktop Version. It is not required for Cloud or Server version.

There may be other uses for Webview. I can’t recall the exact reason it was introduced, but it was probably to do with copy to clipboard.

You don’t need webview to run Manager itself. However you can do the following to fix your problems.

Ensure that your OS is 64 bit. There are now two installers. One for 64 bit and one for 32 bit. The default download link is 64 bit. You mentioned that you are using W10 64 bit, but it looks like Manager is installed as a 32 bit application as Edge is trying to write to c\program files (x86) whereas Manager should be installed to program files.

The second problem is that Manager defaults to installing to c:\users\username… You are obviously installing it to what I consider the correction location -= c:\program files. However when you try to install webview it does not have the permissions to install to that location. Download and install Webview manually, not via Manager and make sure you install Webview as administrator to ensure it has the necessary permissions to install to that location.

The Webview2 error you are getting when you first run Manager after installing Webview2 is Webview2 trying to create a directory in your Manager program directory.

The solution is to manually create this directory and set it’s protection to allow user read write access. The exact name of the required folder is in the dialogue box it puts up first (your third screenshot)

In my opinion a better solution is for the Manager program installer to do this but I suspect that feature is unlikely to be added.

I would say that the solution is to install Manager in a non systems folder such as C:\Manager or to install Webview on it’s own which should bring up admin rights. This will ensure that the correct permissions are set for the folder.

Webview2 already installs in the directory “C:\Program Files (x86)\Microsoft”

The problem is with the invocation used by Manager it stores it’s data in Managers program file instead of one of the following options:

  • C:\ProgramData\Microsoft\
  • C:\ProgramData\Manager\
  • C:\Users<users name>\AppData

The reason programs are put in an operating system program directory is it enhances security. Current iOS Apple’s operating system enforces it. That’s is also why by far the majority of Windows programs are put in c:/programs

I agree that programs should be in c:\program files. No argument from me. But until the developer changes Manager so that it a: installs to this location by default, b: ensures that admin rights prompts come up when installing to a secure location and lastly addresses the issue the OP is querying then my recommendation is not to install Manager in the c:\program files location because it just causes a lot of programs.

Your solution is only necessary because Manager was not designed to be installed to this location.

Manager doesn’t really work well in the c:\program files location due to the limitations of the program. Once this has been fixed then yes, I would be all for it. I have never been in favour of Manager not being installed by default to this location. I am just working around the limitations of the program as evidenced by this topic requested by the OP because Webview cannot read c:\program files\Manager…

1 Like

Unfortunately, that doesn’t work. Even after downloading Webview directly from Microsoft and installing it as administrator, Manager won’t run.

Thanks for the ideas! I’ll continue to use “Fallback to IE” and ignore the error message for now, until this gets fixed.

I install Manager in the same directory as you and this solution enables me to run the current versions of Manager with Webview2

It is probably because you need to do what patch said and apply the permissions manually to the folder in Manager. I wouldn’t wait for it to be fixed because the issue of Manager not installing to c:\program files has been raised a number of times. The developer seems to want an install solution where the program can be installed without requiring admin rights. Why I don’t know.

The solution from @Patch worked for me, with v21.2.17.

Here are the step-by-step directions for installing WebView2 when installing or upgrading Manager, if Manager is installed in c:\Program Files (x86)\ (or anywhere outside of the user AppData directory). As @Patch wrote, it is necessary to change the permissions of the WebView directory within the Manager program directory:

  1. If it doesn’t exist, create a new subdirectory called ManagerDesktop.exe.WebView2 (mind the punctuation) within the c:\Program Files (x86)\Manager\ directory (or wherever Manager is installed).

  2. Change the permissions of the new subdirectory for Users to Full Control (right click the subdirectory > Security > Edit > Group or user name = Users > Allow Full control > OK > OK).

  3. Install Edge Webview2 Runtime from the Microsoft website by clicking the hyperlink when Manager opens, or directly from Webview2 - Microsoft Edge Developer. (Use the evergreen bootstrapper version.)

  4. Launch Manager.

Note that there is a potential security risk, because this gives all authenticated users access to a directory in the Program Files (x86) tree. Use at your own peril.