DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Default Note not on invoices anymore


#1

Tested this morning and the default notes for sales invoices are not on the invoice when previewed or mailed. How can I fix this?


#2

If you were using a custom view template, you might find it has now been disabled. @lubos made bit changes to how sales invoices are generated. So some features that were previously available, even if you customized your template, now are only available if you use the default. I’ve already raised some problems with this in another thread.


#3

@Tut Yes I think it might be disabled, but if I can’t use default notes and Sales Invoice Template is also not available in settings to add payment Terms. Now you have to add these terms to every invoice you generate?

Seems that something is not available to this or it has moved. Another possibility is that I’m missing something here :slight_smile:


#4

I may be misunderstanding you, @durkpotgieter. When I create a New Sales Invoice, the Notes field appears. And there is a blue option to (set default). The text in the Notes box will then appear on subsequent invoices. That is where I am placing my standard payment terms.

The difference between doing it this way and the previous method of placing the information in the Sales Invoice Template settings is that the Notes will continue to appear on the sales invoice even after it is paid in full. Previously, once the invoice was paid, the notes from the Sales Invoice Template setting disappeared.

I find I actually prefer this newer method, because it preserves the sales invoice as it was sent to the customer in case of questions later. Of course, you can always overwrite the Notes.

That said, your problem seems to be occurring, if I understand you, only when previewing or mailing. Not sure what you mean by previewing. Do you mean viewing the sales invoice, or do you mean previewing before printing, or what? If the latter is your problem, it might be tied into the still-incomplete Save to PDF functionality @lubos has been working on. There have been many problems with saving and emailing that he’s fixing with his internal PDF generator.


#5

@Tut
I may be misunderstanding you, @durkpotgieter. When I create a New Sales Invoice, the Notes field appears. And there is a blue option to (set default). The text in the Notes box will then appear on subsequent invoices. That is where I am placing my standard payment terms.

This is what is not happening anymore. Use to work fine. But what I did see now with some testing on diferent invoices is:
Paid invoice it does not work. Outstanding, overdue or unpaid invoice it does work (Default notes are there on email pdf and viewing the invoice). This I can confirm. So it will be an issue when you have to resend a invoice. I would think that paid invoice should still have you default notes, i would understand if the payment terms are not there as it is a paid invoice.

Preview=View button

I would like to be able to still set my payment terms in Setting via the Sales Invoice Template but that seems to be removed. I have payment terms on my existing business but the new one I created this morning does not.
This was the main reason for all this, trying to get default notes working to be able to add payment terms to every invoice.


#6

@Tut I found your previous post on the Sales Invoice Template that has been removed and manager Now auto matically will look for the last number and add 1.
How would you now add you payment terms? Would this be done on Default notes?


#7

What I know (from a private note from @lubos) is that Sales Invoice Template still works for pre-existing businesses that used it. I can confirm this, because my business originally used it, and when I change things in the Sales Invoice Template settings, they change on my invoices.

If you used Sales Invoice Template for your payment terms in your old business, those default notes appear until the sales invoice is paid in full. Then they disappear.

New businesses (sorry, but I do not know the cutoff version) cannot use Sales Invoice Template. Instead, @lubos intends them to make any modifications via View Templates. And the payment terms should go in the Notes field, with the ability to set default Notes. These notes do not go away when the invoice is paid in full. From what you wrote, you seem to agree with me that this is actually positive, in case the invoice needs to be sent again. For that reason, I removed payment terms from my Sales Invoice Template and put them into my sales invoice Notes field.

If this is what you are seeing, things are working as currently intended. Any problems you may have with email or saving as PDF could be unrelated. On the other hand, the reworking of the way Manager generates sales invoices definitely causes some custom templates to drop out of use. I can confirm this because it happened to mine. And the sample HTML code that comes up in View Templates as a baseline for modification no longer includes all features. For example, when an invoice is partially paid, the amount credited no longer appears. Nor do the Paid in Full or Overdue “stamps.” These features are only present if you use the default form.

I think this is a major problem, because it means you cannot “modify” the current, default sales invoice and expect the full features of Manager. If you want something with even minor changes, you have to code the invoice from scratch. But even then, your changes may be left behind if the program changes, because you won’t be modifying the actual code being used. I’ve traded some comments with @lubos about this issue. These are on the public forum.

As to your comment about Manager adding 1 to the last invoice number: this was not a new feature. It has done that since I first started using the program. But your invoice numbers need to be recognizable as numbers. Thus, to include a year indication, you need to start with something like 15001. Next year, manually overwrite the automatic number on your first invoice with 16001 and you will start a new sequence.

Well, that was very long-winded, even for me. We seemed to be saying the same things but not fully understanding. Hopefully I’ve cleared up any uncertainty.