Custom SMTP server / email problem

Hey Guys,
I’m just trying to figure out the custom SMTP sever for sending emails. I use office 365 through godaddy which works well with thunderbird. I am getting errors trying to use it in Manager though.
I have set the following.

Host: imap-mail.outlook.com and left port blank.
Use SSL is on.
SMTP server requires authentication is on.
I have put in my username (primary email admin@mydomain.com.au) and password.

Any Ideas would be great, thanks.

Error I get is…

Transaction failed. The server response was: 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message. 16.55847:280D0000, 17.43559:0000000004020000000000000000000000000000, 20.52176:140F8287000010100B00F77F, 20.50032:140F8287881710100A00C88C, 0.35180:B92A0000, 255.23226:0A000A86, 255.27962:0A000000, 255.27962:0E000000, 255.31418:0A000000, 16.55847:94000000, 17.43559:00000000E0020000000000000100000000000000, 20.52176:140F82870000101003000136, 20.50032:140F8287881710100A00DA36, 0.35180:44000000, 255.23226:4800D13D, 255.27962:0A000000, 255.27962:32000000, 255.17082:DC040000, 0.27745:0A003A66, 4.21921:DC040000, 255.27962:FA000000, 255.1494:64000000, 0.38698:0F010480, 0.37692:0F010480, 0.37948:0F010480, 5.33852:00000000534D545000000100, 4.56248:DC040000, 7.40748:010000000000010B0F010480, 7.57132:00000000000000000F010480, 1.63016:32000000, 4.39640:DC040000, 8.45434:83D1B0DB535C614D95DD1BB9E69D9B570F010480, 5.10786:0000000031352E32302E313932…

Alternatively, if I use my name as the user name (as on my account) I get this error.
SUPPORTBUDDY (2019-06-02) - Email Settings — Edit ul, ol { padding-left: 10px }.float-left { float: left !important; }.float-right { float: right !important; }.text-align-left { text-align: left !important; }.text-align-right { text-align: right !important; }div.content { background-color: #fff; padding: 30px; box-shadow: 0px 0px 5px #ccc; border: 1px solid #ccc; width: auto }a.file-close:hover { color: #999; }#sidenav div { padding: 0px; background-color: #fafafa; box-shadow: inset 1px 1px 0px #fff; }#sidenav img { opacity: 0.4; vertical-align: top; width: 16px; height: 16px }#sidenav .tab-active { background-color: #fff; border-right: none }#sidenav a.tab-link, #sidenav span.tab-link { line-height: 16px; display: block; position: relative; white-space: nowrap; padding: 12px; font-size: 11px; font-weight: bold; font-family: ‘Lucida Grande’,Verdana,sans-serif }#sidenav table { border: 1px solid #ccc; border-top: none; border-spacing: 0px; width: 100% }#sidenav .tab-active table { border-right: 1px solid #fff }#sidenav a:hover { text-decoration: none }#sidenav a:hover img { opacity: 0.6 }#sidenav .tab-active img { opacity: 0.6 }#sidenav span.count { background-color: #FFFFFF; border: 1px solid #CCCCCC; border-radius: 3px 3px 3px 3px; color: #666666; font-size: 10px; font-weight: bold; padding: 3px 6px; }#sidenav span.count-zero { border: 1px solid #EEEEEE; color: #DDDDDD }#sidenav span.tab-label { margin-left: 10px; }#sidenav a:hover span.tooltiptext { visibility: visible }.tooltiptext { visibility: hidden; background-color: #000; color: #fff; text-align: center; padding: 5px 10px; border-radius: 6px; position: absolute; z-index: 99999; top: 7px; left: 42px; }.tooltiptext::after { content: ’ '; position: absolute; top: 50%; right: 100%; margin-top: -5px; border-width: 5px; border-style: solid; border-color: transparent black transparent transparent; }a#feedback-link { color: #ccc; padding: 3px 6px; margin-left: 5px; border: 1px solid #ccc; border-radius: 3px }a#feedback-link:hover { text-decoration: none; background-color: #fff; color: #333; border: 1px solid #999; text-shadow: none }@media print { body { -webkit-print-color-adjust: exact !important; } }

The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM [SYXPR01CA0127.ausprd01.prod.outlook.com]

Is this a 365/godaddy problem or am I just doing this wrong? Should the host be my primary email?
Thanks Guys?
Rj

the port is not to be left blank.
check the imap settings provided by your mail provider and enter the same in Manager.

Also, make sure you click the Update button before testing.
read this guide https://www.manager.io/guides/10643