Custom fields displaying on 2nd PDF page of invoices or quotes

Is it possible to have the custom fields partially showing on the first page, instead of all of them going onto the next page, so basically ending up with 2 pages in an invoice or quote that has three quarters of the page empty and all the info on the second page.

Reasoning is, not all people bother to scroll to the second page and miss the info.


Can you clarify what you mean? On built-in themes, custom fields begin just below the balance due or totals section of the transaction. If yours are appearing on a second page, with most of the first page blank, you must be doing something to cause that. Are you using a custom theme?

Your screen shot does not illustrate the problem you described.

Sorry as i just joined the forum, my membership was suspended temporarily until it was verified. That first screen shot is a normal invoice that has the custom fields on the first page (because the custom fields fit on it).

The second and third screen shot that I will post now, will illustrate the problem.

Is there a way, instead of having all the information of the custom fields on the second page, to have whatever can fit on the first page and the remainder on the second page?

I suspect that you have all that content in a single custom field. Is that correct? When I test this situation, Manager’s internal PDF generator does not break a field across a page boundary. But it will include fields that fit on the first page. So you could solve the problem by breaking up the field into several.

Or, you could use the Print button instead of the PDF button and select a PDF generator as the printer. (Depending on your operating system, you may have this capability to “print to PDF” built in. That way, you fit as much on a page as space allows. You do, however, give up the headings on the second page. But you might consider that a benefit.

Thank you for your reply Tut.

If you look at the custom fields, each bold heading is a new custom field, so no they are not all in 1, so the manager’s internal PDF generator is looking at all custom fields as if it is one, and not spliting them up in each page seperatly.

The other thing is i tried using the print button and saving in pdf but problem on my OS win10 pro is still doing the same thing…

Are you able to get some custom fields on the front page and some on the second page using the internal pdf generator?

Once again thanks for your help.

Yes, I get some custom fields on the first page. Are you using a custom theme?

No im using the plain theme. I have also just updated to latest release and still facing same issue. Any idea why im having this issue?

Not really. I can’t reproduce the behavior.

How are your custom fields defined? Based on the amount of content, they should be paragraph type fields.

They are paragraph type fields. I will install a fresh copy of Manager on a new system and re input the info on that quote and see if it does the same thing. Unsure why you cant reproduce the behavior.

I have installed a fresh copy of manager on a brand new Win10 Pro install, and still had the same behaviour? so I am either doing something wrong to cause it or you are not duplicating exactly my inputs.

I am attaching below screen shots of to print outs, each with 5 custom fields, the first print out has fit everything one page, but when I added 4 more lines of input in one of the custom fields, everything shifted to the second page.

First Test (All on one page)

Second Test (After adding 4 lines of text on custom field 3 - all custom fields shifted to second page instead of only the ones that didnt fit on first page)

I didnt do anything unusal. I installed a fresh copy of Manager on a fresh system. I added customer and sales invoice tab from settings. Added a test customer and test invoice with the inputs shown.

Is there anyway of helping please, its quiet an issue for us.

Thanks in advance.

OK, @Q.Pods, you win. My previous testing to try to replicate this problem used a single-line custom field and another paragraph style custom field. I did that testing with an existing test setup. The single-line field always appeared on the first page. The paragraph-style field only shifted to the 2nd page if the content grew too long. And the first field remained on the first page.

Since then, I’ve updated my software. Now, I cannot produce the behavior I just described. Instead, I see exactly the problem you noted. And it does not matter what type fields are used or how many. If the content of the last custom field exceeds the page limit, all custom fields shift to the second page of the PDF.

I’ve put this into the bugs category.

Yes, this started happening to me also since I upgraded.
It was fine until I upgraded, no other changes were made.

Plain theme should be fixed in the latest version (18.10.26)

has this problem resolved…???

you would have got your answer if you had read the topic completely.

i m on latest version and yet facing the issue…hence