Crashing after Update

Hi, I just updated to version 20.7.14 (the last update was in March) and now it won’t open on MacBook pro with Catalina 10.15.5.

How did you update? Did you follow this Guide exactly: https://www.manager.io/guides/7116?

How did you try to launch the program? Exactly what happened? If there was any error message, show a screen shot of it.

Hello,

I am also having the same problem. I have downloaded the latest desktop version today and I it opens to the “Select Business” home screen and then when I select the business the application crashes.

I have tried to revert to the older version and I can’t open that _ I get a full screen message "Your database has been upgraded to the latest version while your desktop…"etc. I get this screen even when I click on a back-up from 2018.
Help!

I updated as required, but it keeps crashing. As SLoader said, it opens the Business page and then quits. There isn’t an error message, just says Manager quit unexpectedly and gives a report to send to Apple. I tried restarting the computer thinking that would help but nothing. I am unable to open the previous version as well.

I personally bypassed v20.7.14. The problem does not occur on v20.7.16. But it occurs on v20.7.17. I have put this into the bugs category.

The exact behavior I see is:

  • Manager launches and displays Businesses page.
  • All top menu functions are available, such as Preferences and Support.
  • When a business is clicked, the program quits with no error message.

I updated following instructions given and the update failed. Had to restore back up to get it to work. Am on MacOS Mojave.

  • Manager launches and displays Businesses page. [but weirdly and suddenly I had 4 versions of the same business appear]
  • All top menu functions are available, such as Preferences and Support.
  • When any listed business is clicked, the program quits with no error message.

So had to roll back. Clearly something wrong with the latest version.

This was Mac-specific issue. The version 20.7.19 is fixed.

thanks - when did that change because I only downloaded this 1 hour ago

The message was posted 15 minutes ago so the update was probably 16 minutes ago :wink:

Ha ha thanks. I had ensure that any previous versions of the manager files were deleted otherwise it showed multiple accounts.

But all is now working - huge thanks

Working now! Thanks so much for your help!!!

Hi @Tut
I updated the app to version 20.7.22 now and I can’t open the business anymore. I click on the Business name and nothing happens, the screen remains frozen. I try to close the application, and I only manage using Force Quit on the Mac.
My system is Mac 10.15.5
Thanks

@brfranco, this is not a Manager problem. I am looking this very moment at Manager v20.7.22 on a Mac running macOS v10.15.5. I can open and do anything on all my real and test businesses.

Did you update according to this Guide: https://www.manager.io/guides/7116?

Yes, I updated the app according to the guide.

So, the application launches and displays the Businesses page, correct? Have you tried anything else? What happens if you click Preferences or Support? Can you add a business? If you have more than one business, does the same thing happen to all of them? What happens if you click the slider switch for the Learn How To… links?

In other words, is the program completely frozen, or do you have a problem with one business?

I was able to recover the Manager.app v 20.2.34 file and the .manager files by Time Machine and it is now working normally. I recently lost all my Manager files by accident and then managed to restore them in the past, around March / 2020. I believe that there may be remaining files in the Manager folder, because when I updated the app today, duplicate business files were created, such as “Business (2)” for example. I think I should fix the database for my Manager. What do you think? I was taking a look at this forum thread (All business Gone) and I think it might apply to me.

I would not pay too much attention to that thread. (A) It is obsolete, as business files since version 20.6.71 are named with plain text names, and (B) there is a Guide covering management of the application data folder: https://www.manager.io/guides/8394.

Your last version, 20.2.34, dates from the time you say you “lost” all your files. Personally, I doubt you actually lost them, as that is quite hard to do by accident. I think whatever is happening to you might be connected to whatever you did to “restore” your files back in March.

Read the Guide I linked in this post. Follow its instructions to navigate to your application data folder and post a screen shot of its contents. Include the information on modification dates. (Adjust to List view to see that information, if that is not already your view option in Finder.)

All fixed now - thank you!!!

@Tut Thank you very much for your support. I managed to solve the problems. It is now working normally with the latest version 20.7.25

I am curious how you resolved your problem, @brfranco.