Copy and paste

How do I copy and paste from the package on excel so that I can use a formula. I can copy and paste to excel but the amounts have to be retyped out so that I can use formulas.

How do I copy and paste the amounts on excel and not have to retype for me to use formulas

1 Like

Click on the “Copy to clipbboard” button

  • at the top of reports
  • at the bottom right corner of most other screens

Then paste into a spreadsheet

@Patch @mick I think he wants to know how to get the amounts to values in order for him to do calculations on the spreadsheet. I do not think it can be done. I have experimented with it as well by changing the cell formats to numbers and so on, but no success.

When you paste from Manager to excel what do the cells contain?
Some spreadsheets import numbers as text.

Not sure what you want to copy and paste, but if for example, you searched for a set of payments under Payments, you can just with your mouse select all the data needed (excluding the edit and view buttons) and then for example sum the amounts (that works!). If anything, for any table representation in Manager inclusive of “Summary” you can select the data and copy and paste into Excel to further run calculations on.

Update: copy to clipboard a @Patch explains works as well, at least with Microsoft Excel version 16.49 for macOS. Are you sure you are using Excel as spreadsheet?

@Patch @mick I changed the format of the cells, but in vain. I think it can not be done

Please provide screen shots of

  • what you are copying in Manager including the bread crumbs ( the path of how you got there near the top of the window)
  • Import options you have selected when pasting into excel
  • What is actually in a cell you want to reference as a number (click on the cell and include the menu bar in your screen shot)

I and may other users are successful do similar things frequently

@Patch @mick

  1. I start with selecting the report to copy into excel
  2. I select "Copy To Clipboard
  3. I open the spreadsheet and select paste
  4. I autofit Columns
  5. I select Value Column
  6. I change the Column Value to “Currency” or “Numbers”
  7. I try to add the values with the Sum Formula

If for some reason Excel is not treating the digits as numerical values and will not respond to changing the number format via “Format Cells…”, something you can try is to select the cells affected, then choose Data > Text to Columns, then simply select “Finish” in the dialog box that opens.

@p4unger It also does not work

You have imported numbers as text.

The reason I asked you to

  • click on one of the cells and show the menu bar is I wanted to see if excel had quoted the text on import to prevent conversion from text to numbers. And

  • to show any paste special options to determine import data format options you have chosen:- Text, Number, General

And if you can’t import the text as numbers

Sorry, using Manager v21.5.37 on Ubuntu 20.04 Server and on macOS Catalina followed similar steps and had no problem copying and pasting and applying Sum(…) to selected numbers with Microsoft Excel version 16.49 for macOS. Can you please indicate similar information about Manager version and Excel version.

Update: Tried Libre Office v7.1.3 for macOS and no issues either.

@Patch @eko @p4unger @mick This is a cell selected, but it does not want to do a screenshot with the right click menu. I am using “snipping tool”

We would like to see the formula that results in #VALUE! as the error is with the formula. So show us a full screenshot that includes the formula entry as in screenshot, obviously we need to see all the cells you try to sum.

Screenshot 2021-05-29 at 08.59.48

Numbers imported as text often have a single quote as the first character in the cell.
Going in to the cell and deleting the quote or just editing the cell maybe enought to convert the string from a text string to a number.

Past special probably also gives you import options which are likely to help

Failing that a formula in excel =Value() or = NumberValue() will work

you cant sum text only numbers

@Patch @eko @p4unger @mick Okay I did it again, now it does not give a value anymore. It gives a number, but does not sum it.

I am just thinking. Could it not be because of the negative numbers?

Your formula sums B12 to B49. But you only show B28 onwards. This time you do not have a #VALUE! message so it seems the formula worked.

When you have a number in the cell, the number formats will work

When you sum over only numbers the sum formula will work

Indeed, however I followed the steps using Copy to Clipboard of P&L and past in Excel, Number and Libre Office had no problems using formulas n the numbers in the amount column.

@eko @Patch @p4unger @mick It is because I did not Screenshot the full screen