Importing a backup file

When I want to add new business and press ‘Import backup’ I’m not able to select the file I want.
When I locate the backup file (xxx.manager) in Finder and try to open it I get an error “Manager cannot open files of this type”.

The only way of importing a back up file is to drag it and drop on the ‘Choose file’ button and then pressing ‘Import’.

Could anyone help me with my problem? I’m using a Macbook Pro.

You cannot open .manager files directly. Manager calls these files to use your data. On a Mac, you should have dragged the application icon into your Applications folder. Double-click the icon to open, like any other program. By the way, there was a recent software update that may require you to restart you Mac (one time) for verification before Manager will open. That will depend on exactly which version you have and how recently you may have restarted versus put the machine to sleep.

Hi,

Thank you for the quick reply. I’ve tried everything: restarting the computer, redownloading/reinstalling Manager (with dragging to Applications). I’m still not able to choose a file and import it. After choosing the backup file and pressing ‘Open’ nothing happens and I’m back in ‘Choose file’ dialog box. All my software is up to date. Standard/default settings. I didn’t have this problem on my older Mac. I have a new Macbook with a solid state drive - could there be any compatibility issues?

Thanks
Marius

There are no compatibility problems. Are you following the procedure described at the bottom of this Guide page: http://guides.manager.io/businesses? The reason I ask is because you shouldn’t be presented with an “Open” button during the process. The business should appear in your list of businesses; you click on the business name to open it.

Do I understand correctly that you have not actually used Manager yet on your new MacBook? You have only installed Manager and tried to transfer your records from your old machine via the Add Business function?

Maybe I just realized what you were saying. If you were referring to the Open button in the Mac OS X Finder window, which you used to navigate to the backup file, that should return you to Manager’s dialog box, not open the file. (That’s a long-time quirk of OS X; it says Open when perhaps it should say Select.) When you get back to the box, all you have done is select the file. You must then click Import Backup.

I am having a similar problem on a Mac Book Pro. When I attempt to import a backup file, I am asked to select the file. This sends me to a directory where the backup resides. Clicking the backup results in an option to open it or cancel. “Open” returns me to the select file page and give the message “No file selected”.

Incidentally, while I think Manager is a great program, I find that it quits unexpectedly quite often.

JB

What version are you using? This has been fixed long time ago.

Hello Lubos

Many thanks for the extremely rapid response. I am using Manager 16.4.46

Then try to upgrade to the latest version from https://www.manager.io and see if the problem persists.

Thanks Lubos; that fixed it!