Cannot install Manager

I was getting an error with sending emails on my version of Manager & read that the fix was to upgrade. So I tried to install the latest version, but keep getting an error:

Could not create key:
HKEY_USERS32\S-1-5-21-14384392223-1964663411-1553072458-1001\Software\Classes. Verify that you have sufficient access to that key, or contact your support personnel.

I have administrator privileges on my Windows 8.1 system. I also tried turning off Windows Firewall. I also did a system clean and restart. Still no good.

Can anyone help please. I really need to access my files.

Well I think I fixed it in a round about way. I did some searching on the HKEY message and read to try using an exe rather than msi. So I downloaded ‘source package’ instead of direct download. Unzipped, then ran the application file. Had to play around a bit to add the icon etc. But it seems to be working now.

Well there’s an obvious reason for that part - there’s no “HKEY_USERS32” root in the registry tree. What might have caused Manager’s installer to try creating anything in that non-existent realm though is a mystery to me.

I managed to entirely skip Windows 8.x (as I did Vista and Windows 10), but I do have several Server 2012R2 instances running (which share a common base with Windows 8.1), so might do some experimenting to see if I encounter the same problem.

FWIW, this discussion thread on GitHub suggests;

in almost every case, the solution was to make the installer install for ‘Everyone’ instead of ‘Just Me’

That’s something I do for every application I install anyway, and if it’s something that other users of a computer shouldn’t be able to access, I then restrict access to the application through policy/permissions.