Cannot input a date by typing manually

Hi. Hope you all are doing well. Since i updated to the latest version of manager desktop today, i am unable to put in any payment/receipt/payslip etc. date manually which i was able to enter before the update. Now the built-in calendar pop-up doesn’t identifies the manually typed date, and to input the date one must have to select it from the drop box only, otherwise either it selects current date or takes it as a blank. Anyone else having this problem? Also the calendar now looks quite faded, like its kind of disabled or so, previous one seemed better.

Manager Desktop Edition 21.9.18
Windows 7 x64

You need to type the date in exactly the format you have chosen under your Date and Number Format setting. For example, if you have selected a DD/MM/YYYY format, but you are entering March 3, 2021, you cannot enter 3/3/2021. You must enter 03/03/2021.

sorry but i do not find this as a valid explanation in this case.

as you can see below is my date settings in Manager.


below is what i see when entering a transaction.


but after creating the transaction, it displays the correct date format everywhere.

i believe the valid suggestion would be to enter the date in a format as displayed in your transaction form.

@FaridKhan on version 21.9.15 when i manually type the date as displayed on the transaction form, Manager does accept it. i am not sure about the latest version though.


It used to work for me as well before the update. I have tried putting the exact format in the form, it seems manager only picks up the exact format as defined in the settings, otherwise it wont recognize it. Mine was set to accept DD/MM/YYYY and that is why i was having trouble with putting in DD-MM-YYYY or DD-MM-YY. This pretty much solves it. Thanks.

1 Like