DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Cannot attach multiple files at once (Desktop Edition)


#1

Tested on:

macOS - Desktop Edition 17.9.40 (broken, as below)
Win 10 - Desktop Edition 17.9.40 (works perfectly fine)
Ubuntu - Server Edition 17.9.40 (works perfectly fine)

How to reproduce:

When uploading multiple files at once (try 3-4 on a Sales Invoice or Folder) by using drag-and-drop onto the form, the application hits a locked database and is unable to upload more than the first one.

I see messages like this:

And this:

So the application is trying to upload them all at the same time and hitting a locked table, and it’s trying to assign all of the files the same key / record ID.

I run into this issue mostly when using Folders, because that’s when I want to upload multiple files at once. However it can be reproduced anywhere files are attached.


#2

I learned something from you, @ShaneAU. I did not know you could attach documents by dragging and dropping. And I’ve never seen anything anywhere that suggested more than one file could be attached at a time.

I tried to reproduce your reported behavior and discovered that the error messages occur only when dropping multiple files onto the New Attachment button. If you drop multiple files elsewhere on the form, they attach with no problem. I did this test with desktop v17.9.40 running on macOS 10.12.6.


#3

Glad to hear that! :slight_smile:

Very intriguing. This is certainly not what I noticed.

I’ve been dropping them onto the form itself, not on the button. Just did a quick sanity check then and can confirm that I am not dropping it on the button, and still get the issue.

Perhaps it has something to do with the size of the files (and therefore how long it takes to attach each one)?

I have several PDFs that range from 29 - 32 KB each.

Used the same files between my Desktop + Server tests, and consistently have it working on Server 100% of the time, and consistently not working on Desktop 100% of the time.

Running macOS Sierra 10.12.3, Manager version matches yours. Not sure what else to check. Hmm.

Here’s an example of me dragging the files across from the Finder window. Where the files are now, that’s where I let go of the mouse and they start attempting to attach:

This is for one customer, I have multiple folders of PDFs that I intend to attach. Have tried a number of different PDFs and the problem persists.

Sometimes uploading two at once works. But it fails 100% of the time for me with 4 or more.


#4

My first test was with just two files, but both were larger than yours. One was 172 KB and the other 860 KB. When I add a third of 90 KB, I get the same error you got. I’ll elevate this as a Bug.


#5

Aha. Then size has nothing to do with it, and it’s quantity.

Does it consistently fail with 3+ for you, or occasionally succeed?

Thanks


#6

5 tests of randomly selected groups of 3 files all failed. Further, several tests with 2 files failed, even though the files were smaller than the original two I mentioned above. But some groups of 2 files succeed. I haven’t discerned what the limits are, though.


#7

I have tested on Windows 10 and can confirm that it actually does work on that Desktop Edition.

My original post has been edited accordingly.


#9

Fixed in the latest version (17.10.2)


#10

Thank you - I can confirm that it is fixed (tested on 17.10.7)