Attachments to invoices not attaching


I’m having an issue with attachments to invoices not attaching. In the past I’ve always been able to attach these PDF’s either by dragging the file over the new attachment button or clicking it and doing it that way, but now I see the file name and an upload percentage of 0% next to it. I found recently since the problem started that I could upload one attachment before having to restart the app but now that’s not working either. I haven’t changed how I create the PDF’s and I have tried uploading supplier invoices to see if the problem is with my files but no change.

I know it’s a little backwards, I record my income and expenses in Manager, then attach PDF invoices created in Indesign which are the ones I send out to clients for a more polished look.

I have updated to to see if that helps resolve the issue but no change. I’m running Mac OS Ventura 13.1

Thank you in advance

The latest version is, so you are not using the latest version

Strange, I downloaded this on Friday. I have just updated again and can confirm I’m using now. The issue is still happening for me in this version.

I don’t have any problem attaching a PDF file to a Sales Invoice by clickiong on the button and selecting the file

I am using the Desktop edition on a Windows 10 PC

I cannot replicate this problem on macOS v13.2.1 and Manager v23.3.13.692. How big is your InDesign PDF, @Metagraphics?

That doesn’t matter. Sometimes, there are multiple releases in a single day, usually when bugs are being fixed. So you should always make sure your software is up to date before reporting problems.

The PDFs are only small, single page usually, less than 50KB file size. Even trying to attach PDFs that previously worked on other invoices won’t attach so I don’t think it’s the files themselves.

How are you attempting to attach? Is it drag and drop or using system dialogue?

Personally, I used drag and drop in my test. That has previously given the most problems.

I have tried both. I would usually drag and drop but I’m aware this can be a little finicky so tried the traditional dialogue too.

I had to restart the mac a few times today to update some other programs, I thought I would give it another go (I have tried a restart before but it didn’t make any difference). This time I’m able to attach one file to an invoice, if I try to attach any more files I can’t unless I quit the app and relaunch for each file. This is how things were behaving recently before I was totally unable to attach files.

I repeated my test. I am still on MacOS v13.2.1, but have updated to Manager v23.3.15.711. I cannot replicate the original problem. And I deliberately added multiple attachments with no problems.

I would try updating your operating system, since you are behind the currently available public release. Perhaps there was a bug there that has been fixed.

Re installing the Manager application may also help.

Apologies I should have said, I have since updated MacOS to 13.2.1 and no change unfortunately.

How do attachments in Manager work? Do they simply link to the files existing location or do they copy to another location? If so where would that be? Perhaps I could check if the permissions on that location have changed somehow.

Attachments are incorporated into the data file for the business.