DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Cannot add Business


#1

I have downloaded Manager. When I click on blue Add Business button nothing happens at all. I restarted the computer, uninstalled the program and installed it several times it does not do anything. I am using Windows 7. Can anyone help?


Trying to add a business on desktop version
Unable to Add New Business
Trying to add a business on desktop version
Sales invoice - screen form jumbled
#2

When you go to Internet Properties (you will find it in your control panel)

What is your security level for Internet and Local intranet options?

The reason why the button wouldn’t work is that you have javascript disabled in Internet Explorer. Manager is using Internet Explorer to show user interface.

On Internet Options window, clicking Reset all zones to default level button should fix the issue.


#3

Thanks lubos. I am talking about desktop Manager. Does your comment applies to desktop edition?


#4

Yes, it specifically applies to desktop edition on Windows.


#5

I did all you said but it is not working. I uninstalled Manager and reinstalled it with new internet security option but no luck any other comment?


#6

Another way to fix it is to install server edition.

  1. First install and launch server edition - see tutorial: http://www.manager.io/server/tutorials/windows/
  2. Then open Internet Explorer (must be Internet Explorer, not Firefox or Chrome) and navigate to http://localhost:8080
  3. Create first user, then you should see the same screen you see on desktop edition with Add Business button which will still not work…
  4. There should be yellow bar at the top of IE warning you that something is disabled (that’s why Add Business button doesn’t work). So just confirm or enable something that you are being asked too.
  5. Add Business button should be now working… close the server, close Internet Explorer and open desktop edition of Manager where Add Business button should be working too.

#7

I’m having the same issue. Manager Desktop once installed is unusable i.e. I can’t add a business, nothing happens. I’ve reset IE security options and am using the latest version. I can try Manager Server but that isn’t really addressing the underlying problem as to why Manager Desktop isn’t working.


#8

The steps related to server edition will fix desktop edition. It’s not like you have to keep using server edition. It can be used to fix the underlying issue.


#9

Sorry I misunderstood the instructions. I thought you meant use the server version instead.

Anyway I just tried the desktop version again and it still doesn’t work. I launched server again and that works in IE. After closing server I tried desktop version once again and it still doesn’t work. The business I was successfully able to add in the server version does show up in the desktop version but clicking on the business link does nothing.


#10

If you like, we can arrange TeamViewer session and I can have a look at this myself. Send me an email to support@manager.io


#11

I don’t know if this is relevant but just in case I’ll post it here also.

I’m a web developer and I’ve had a strange issue whereby IE F12 developer tools window is blank. This problem arose after a Windows update last year. There are a few mentions online of this issue and I’ve tried every suggestion short of a complete Windows reinstall in order to fix it, but to no avail. Other than that IE is up-to-date, as is my Windows 7 64 bit. I’ve also disabled all IE plugins in case one of those might have been interfering somehow.

So maybe this is linked to my issue with Manager Desktop, but maybe not …


#12

Not sure if it’s related, my initial guess would be that it’s not related. The reason why Add Business button doesn’t work is because Javascript is not executing in desktop edition. I’ve seen this happening only on Windows where Internet Explorer refuses to execute javascript in intranet context. It needs to be explicitly enabled.

So for now, I assume that would be your case too although you are sort of disproving it by saying everything works fine in server edition. I would need to see it by myself.


#13

I’m having the same issue. Manager Desktop once installed is unusable i.e. I can’t add a business, nothing happens. I’ve reset IE security options and am using the latest version. Javascript is enabled. Also tried reinstalling as administrator, same issue. Was this issue resolved for others?
BTW, http://localhost:8080 will not run in IE for me.
thanks!


#14

@magmp, if it’s not the issue above then it’s best if you email me to lubos@manager.io and arrange some TeamViewer session.