Business Name on Invoice

Hi,

Is there a way to get rid of the business title on top of sales invoices? I noticed Manager started adding this title lately.

Thanks

read below topic.

Manager has always placed the business name here. This is not something recent. If you do not want the name to appear, leave the field blank under Business Details in Settings. But that will also leave the name off many reports and in other locations.

But why would you want to issue invoices without your company’s name? How do you expect the customer to know who the invoice is from? Your country’s tax laws also probably require your business name to be on the invoice.

If the Theme is changed to one of the styles below the Plain Theme the Business Name and Address comes in the footer in small fonts

Manager always added business details on top of invoices, but only if those details are added in settings, in my case, I don’t have business details in settings, I always had that section empty so consequently invoices had no business details on top of them.

After updating Manager yesterday, it started adding business name on top of invoices, so where did Manager get this name if I have business details section empty in settings? It got it from the business name itself that shows up in summary page, or when you first open Manager under businesses tab, this is the source of business name Manager added:

That is only true for some themes. Many of the built-in themes place business details at the bottom.

You did not answer my earlier question about why you would not want customers to know your business details, or even who is sending an invoice.

Yes, that is what the program does, as explained in detail in this Guide: Name or rename a business | Manager. There is even a prominently displayed Note:

I did not fully explain this in my previous post, because I was making the point that the behavior of placing a name in the location you are complaining about is not new. And I wanted you to understand that leaving it blank would create blanks elsewhere on forms and reports.

The relevant Guide has contained similar language since April 2017. So your old version must have predated that, meaning you were literally thousands of versions out of date.

Tax evasion :smiley: (Kidding)

This is not accurate, we started using Manager only in 2019, also I update it every month, sometimes several times a month (per updates availability), I always had business details empty, and Manager never used business file name as a replacement.

Here is a sales invoice I found screenshot on my phone earlier before the last change:

Do not expect support in the program or on this forum for that.

I don’t think it is appropriate to joke about this subject, but I do understand the sentiment that the reason for your request is not really relevant in this instance and other forum members should not demand it.

I can think of a perfectly valid reason for this and that is that a business may have pre-printed stationery with business logo and details.

I would suggest that the solution for you is to place a single dot (period, full stop) in the business details in settings.

I was kidding :smiley: but not expecting support anyway, cause no one seems to have a clue of what I’m talking about, it seems like a glitch in all previous versions that was fixed this time

1 Like

Although I don’t feel I have to explain to anyone about the details of my business, but the reason behind hiding details in customers’ invoices is simply because we operate the same business under 2 different legal registrations, one is medical and the other is commercial that owns the medical one, some customers (medical) can’t do business with non-medical entities, others need special permission to do business with a medical entity, as you can see; there is no one business details that can fit all customers, although all of our businesses and licenses are completely legal and abide to law, it is still a situation that we have to choose between running 2 different versions of Manager according to customer type or simply hide which of our 2 entities is actually doing the business with each customer, we chose the latter and I don’t have to explain why to anyone :slight_smile:

Then please edit your post to remove something that has no place on this forum.

I understand quite well what you are talking about. But if there was a “glitch,” it was on your end, because the program did not change in this regard “this time,” whatever that means, since the program is updated almost daily. You have not addressed, for example, whether you might have been using a custom theme, which would allow the business name to be suppressed.

Custom themes are also the way around your situation of multiple business registrations.

1 Like

I tried many times the custom themes but always had same business details show up, and couldn’t get rid of them in either theme, it seems I need professional help to design a custom theme for one of the businesses.

Thanks guys

I agree with @sigmas55, this isn’t the expected behavior. In fact, in the code of the themes this entire section existence is depends entirely on whether the business address is filled or not.

This is the plain theme code from Cloud version 21.10.33

{% if business.address != null %}
<td style="width: 20px"></td>
<td style="width: 1px; border-left-width: 1px; border-left-color: #000; border-left-style: solid"></td>
<td style="width: 20px"></td>
<td style="width: 1px; white-space: nowrap; vertical-align: top">

<div style="font-weight: bold">{{ business.name }}</div>
<div>{{ business.address | newline_to_br }}</div>

{% for field in business.custom_fields %}
<div>{{ field.label }} {{ field.text }}</div>
{% endfor %}

</td>

{% endif %} 

Even if you fill in your business name and leave the address blank, this section shouldn’t show. That made sense and that’s what’s to be expected.

@Tut please consider reclassifying this to bugs.

Well, my production version is 20.8.67 so this change was introduced since august 2020.

Using html-code <!-- and --> like in:

                    {% if business.address != null %}
                    <td style="width: 20px"></td>
                    <td class="border-start" style="width: 20px"></td>
                    <td style="width: 1px; white-space: nowrap">
                        <div style="font-weight: bold">{{ business.name }}</div>
                        <!--<div>{{ business.address | newline_to_br }}</div>
                        {% for field in business.custom_fields %}
                        <div>{{ field.label }} {{ field.text }}</div>
                        {% endfor %}-->
                    </td>
                    {% endif %}

in order to not show the business adress results in:

Yes there is: edit the Plain theme and add and title != 'Invoice' %} to line 22 so it becomes
{% if business.address != null and title != 'Invoice' %}

This will remove all business details from the Sales Invoice only. All other documents and reports will still include them.

1 Like

There seems to be some unwanted interactions.

Try using {% comment %} and {% endcomment %} instead

this is true.

the plain theme by default is coded to not display the business name and business address if the business address under Settings is left blank irrespective of the business name field contents.

this is a bug. @lubos @Tut

This worked, I set the new theme to be auto-selected in form defaults, the only problem is this does not apply to old invoices, unless I manually edit them one by one.

Thanks Mark