DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Bug in OS X desktop edition


#1

Not sure if just my setup.
OS X 10.10.5
Typing in the search box of an account and using return (enter) key on keyboard results in spinning whee and forced restart.
Using the mouse to click search button has no problems


#2

That doesn’t happen for me. But I’m using OS X 10.11.2. I don’t remember it ever happening before I updated my OS either. What version of Manager are you using? Make sure you are up to date and then try and let us know.


#3

This also happen on my OSX. It happen when the search word is not in the dictionary and I press enter without clicking the ‘x’ mark.

Example:
i search for ‘amc’ the OSX dictionary will suggest ‘mac’, if i did not click the ‘x’ and enter, then the whole programme need to be restart.


#4

Thanks, @Annie_Wong. With your example, I was able to reproduce this problem. It seems to originate within the autocorrection routine. That is, the routine is suggesting an entry, but you press Enter while the routine is still waiting for an answer. Same thing happens in a few situations I could identify quickly:

Type “hte” and autocorrection suggests “the”.
Begin to misspell “January” as “Janaury”. By the time you get to “Janau…” it suggests “Jana.”

I don’t know if this is OS X-specific or comes from within Manager. I suspect it may be OS X-specific, because I often correspond in my business with someone named Jana. @lubos will know for sure.

It does seem, though, that a better response would be for the suggested autocorrection to be entered. The worst that could happen then is a search with the wrong parameter, rather than a non-responsive program.


#5

This looks like OS X issue. Is this happening in all fields or only certain fields?


#6

I did not do an exhaustive search, but as nearly as I can tell, it happens in any Search box, but not in data entry fields.


#7

I ran into the same issue on OS X, after upgrading from Mavericks to El Capitan (version 10.11.2).

It happens in any search field and only if ignoring the autocorrect suggestion without clicking the ‘x’.

On this page, it is described how to disable autocorrect globally on OS X. However, I’d like to keep autocorrect globally enabled, but have it disabled only in Manager. Would that be possible?


#8

Tomasz,

You nailed it - tested that and it seems to solve the issue… obscure but easy to fix if you know about it.
Hopefully others will come across this post and it will help them.

Cheerio

James


#9

Turning off Autocorrect is not the issue, @jamesd and @tomasz, though I’m sure some users found the link informative. The issue is why this causes Manager to be unresponsive. That does not happen with other OS X applications, so far as I know. Note that, when it happens, it is only Manager that hangs up, not OS X. So I still believe there is something about Manager’s search routine that is involved.


#10

@Tut I understand that it must be an issue in Manager, because other applications in OS X do not hang in the same situation.

Because each time I’m working in Manager I cause Manager to crash when using the search field, I was looking for a fix or at least a temporary fix to use until the issue is solved. So, the link was just a temporally solution and hopefully useful for others as well.

I have faith that @lubos will find a solution for this issue.


#11

Could you test the latest version (16.1.34) whether this issue is still present?


#12

The problem is still here.
Mac OS X 10.11.3
Manager 16.1.34


#13

I tested version 16.1.50 on OS X 10.11.2 and the issue still persists.