Bug in "Copy to Clipboard" for Payment/Receipt

Discovered Manager.io recently and have been importing the past 2 years of my small rental business. I absolutely love it, thank you for your excellent work.

I noticed that the “Copy to Clipboard” feature for Payments/Receipts is copying a Dictionary object’s “toString” into the “lines.CustomFields” column, instead of serializing that Dictionary to be unserialized later.

I tried to find a category for this but can’t figure out forum categories, for some reason.

Thanks again for your great work!

It is not clear what you are asking or saying. There is a Copy to Clipboard button for the Receipts & Payments tab listing. There is also one for the Batch Update function. What are you trying to do? And are you suggesting something you are seeing is a problem? If so, describe what and why.

Also, you have used terminology not used in the program. What exactly are you referring to as the “Dictionary?” And what are you referring to as the “toString?” What do you expect to be “serialized” or “unserialized?”

I suspect you are trying to do something with Batch Update. Regardless, all results from Copy to Clipboard everywhere in the program are in TSV format. See the Guide: https://www.manager.io/guides/10645.

Regular forum members can only post to the uncategorized category. You can view ideas and bugs, but only moderators and system administrators can post or move topics there.

Hi Tut,

I’m not asking anything, I’m just pointing out something I think is a (small) bug. I am indeed referring to the “Batch Update” function, and the terminology I was using was referring to the programming language that is apparently being used.

I’m using some custom properties on my Payments/Receipts, and when I Copy to Clipboard and paste into an Excel-like program, I notice the “lines.CustomFields” column is occupied with this:

System.Collections.Generic.Dictionary2[System.Guid,System.String] System.Collections.Generic.Dictionary2[System.Guid,System.String]

Which I believe is the .NET programming language attempting to serialize a Dictionary mapping GUIDs to Strings. But I believe the intention here was to either include something editable (like a JSON encoded representation of the Dictionary) or maybe to omit this column, if the data is actually not editable.

This isn’t affecting my workflow at all, but appeared to be unintended.

I had the same issue but have just updated to 20.10.94 and think it has been fixed.

Could you update and report back?

@jtc, who are you asking to update and report back?

@catgambler if they wouldn’t mind :slight_smile:

I may be also experiencing this issue after updating from a version earlier this year which didn’t have this issue to the latest version. I’m using MacOS Big Sur 11.1, Manager 20.10.94, and for me right now when going to “Receipts & Payments” and clicking the “Batch Update” button at the bottom and then the “Copy to clipboard” button on the subsequent page, nothing is added to my clipboard.

I’m going to restart my mac and see if that fixes the issue, but considering the person who started this thread also seems to be experiencing this I’m doubtful restarting will fix it.

I’m not sure the exact version of Manager I was using before this latest release, but I think it was around 20.10.50-ish, and that version definitely didn’t have this issue. I know it didn’t have this issue because I was using that version an hour ago and used this feature.

Hope this helps.

@kazango, you are experiencing a different problem described in a known bug report: Bug with "Copy to Clipboard" - #17 by lubos.

This is specific to Macs and will be fixed within a few days. The workaround is described at the link above.

Thanks, the link mentions the server edition, I’m using the Desktop Mac edition so I’m not sure I can open anything in a different browser - correct me if I’m wrong

Following up after reading the rest of that thread, I think it was you (@Tut) who said to right click on “Copy to clipboard” and select “open in a new tab”, or drag it to a browser. Neither of those works. Right clicking on the “Copy to clipboard” button in the batch update screen gives options for “Back” and “Reload”. Dragging that button to a web browser does nothing at all, it’s not draggable on Mac.

You right-click on the Receipts & Payments tab name, not the copy button. You can definitely open as many instances of Manager as you want in a browser. Everything in blue in the Manager window is a hyperlink. Just drag one—any one—to the browser’s URL window.

Oh wow now this is something :sweat_smile: Thank you for clearing up that workaround - I can confirm that works perfectly, and I can also see several use-cases for it rather than using multiple screenshots while adding new data. Now if only I could figure out how to import PayPal statements since the payer/payee updates

Do you have PayPal set up as a bank account under the Bank Accounts tab.
If yes, then use the “Import Bank Statements” process.

@Brucanna Yeah I do, and that worked fine last year but they’ve since changed the way customers work with Payer/Payee “Customer, Supplier, Other” categories and the names are no longer imported. I made a separate thread about the issue How to import PayPal/Stripe statements after Payer/Payee update? - #4 by kazango and it doesn’t look like there’s a workable way to do it. In the end I just manually went through and added all the names for each transaction after importing. A real pain considering it worked fine last year but :man_shrugging:

Scratch that, the issue does persist. Now on 20.10.97, Desktop, Windows 10 20H2 19042.685

Steps to reproduce:

  1. Open or create a Business with the Receipts & Payments tab enabled
  2. Create a new Receipt or Payment
  3. Now on the Receipts & Payments list, go to Batch Update
  4. Click on Copy to Clipboard
  5. Upon pasting the data, observe that the Lines.CustomFields column for your newly created Receipt/Payment contains the data System.Collections.Generic.Dictionary`2[System.Guid,System.String]

Have you tried using mm/dd/yyy date format? Because this is the only format supported for bank imports since a few months ago.