Bug with "Copy to Clipboard"

Working on Windows 10 Manager 20.10.84.

@lubos, any update to this? Ver 20.10.90: still “copy to clipboard” is not functioning

@pandhm are you testing in desktop edition on Mac?

@lubos i am using licensed manager server ver 20.10.90

@lubos, I am not sure what was changed, or at which version. But the Copy to clipboard function also no longer works on Batch Update. (When I first moved this topic back into bugs, it worked for Batch Update, but not for copying reports. Now it works for neither.)

OS is macOS v10.15.7. Manager version 20.10.90.

@pandhm which web-browser are you using? Can you try different web-browser to see if the issue persists?

@Tut the workaround is to open Manager in external web-browser where Copy to clipboard button should work. I’m waiting for third-party developer to improve something at their end which will fix this. I was told it will happen within a week or so. If they can’t do it, I will work on alternative solution.

1 Like

The function works for both Batch Update and on reports in an external browser. So that is a viable, though irritating, workaround.

Please advise how to open Manager Desktop in an external web browser?

@lubos Firefox 83.0 and Edge 87.0.664.60

For a mac see

In windows see

Thank you.

@lubos, please inform us about the solution for the problem “Copy to clipboard”

I am trying to use Copy to clipboard in Receipts and Payments. I had not installed the webview2 component (so was falling back on IE) as I was using the desktop version to test the batch update before updating the live server version.

The copy to clipboard does not work in IE fallback mode.

1 Like

@dalacor, I know you have been using both server and desktop (for testing) editions. Which one has this problem? At least one bug with the function was already fixed. Others are already documented.

Your post was moved to the existing bug discussion.

The server version is the live version, which is on the June version. I still have to update this. I have the latest version of Manager on a desktop install and it is with this that the problem is occurring.

When I update the live Server version, I will test the copy to clipboard and see how if it works. I don’t know whether I need the webview for the server version or if that is a desktop client only requirement.

Anyway installing the webview on the desktop version seems to address the copy to clipboard apart from one strange line appearing - that is not a transaction and has an odd date. I just deleted that entry.

On the Server version, the copy to clipboard works with or without Webview2 installed. So only the desktop version is affected in that Webview2 must be installed for this to work.

The only bug that remains (for me at least) is with this strange receipt transaction dated the 1st January 2001 - long before I started using the program and also with no amounts and most of the fields empty. I just deleted that row and everything seems to be ok. No idea where it comes from though.

1 Like

Yes - I have noticed that too!

@dalacor @jtc the issue with batch update fixed in the latest version (20.10.94). It is actually an entry from Form Defaults which batch update was not ignoring. It is ignoring it now.

1 Like

@pandhm I’m not sure why is this broken for you in both Firefox and Edge. Can you try another computer? This looks like something installed on your computer which prevents web-browsers to modify contents of your clipboard.

@lubos I have tried another computer. When I select the data of the report and copy them, then I can paste them to excel, but with “copy to keyboard” button nothing is copied to clipboard