Blank First Page

Ok, searched the forums and found nothing.
When I print a General Ledger Transactions Report using the ‘Print’ button I always get a blank first page.
I get it no matter whether I’m printing to a physical printer or any of the three PDF printer devices.
However, if I use the ‘PDF’ button it is OK.
This is the only report I have come across that does it.
I’m using 18.11.39 on windows 10, but it has done it since I installed Manager around 2 years ago.

And does it happen if you use the latest version?

Just double checked and it happens in a lot of the reports.

Do you mean a totally blank first page or headings with no line items? Other people have reported the first, which seems to be related to your operating system, not Manager. If the second, I think you’re the first to report that exact behavior.

A totally blank first page on any report longer than one page.
I fail to see how my operating system has anything at all to do with the problem.
I have used a cannon printer, a HP printer, Foxit PDF printer, Microsoft Print to PDF, PDF Creator from both a Windows 10 and Windows Vista computer all with the same result.
Using the PDF button does not produce the result.
No other program or printing from my browsers has this problem.

It is as if a page feed is being generated at the start of the printed report, but only if it is more than one page long???

As a bit of advice, you need to describe issues completely if you hope for help. You initially said:

  • The problem happens only with the General Ledger Transactions report. That implies a problem with coding for the specific report.
  • You always experience the problem. That also suggests a report coding problem.

Next, you said:

  • The behavior occurs with a lot of reports. That suggests different kinds of problems that affect multiple reports.

Now, you’ve said:

  • This only occurs with any report longer than one page. That points towards pagination issues that could have still different sources.

And you have not answered my original question:

  • Are you getting an entirely blank page, or a page with headings but no other content?

Until the problem has been accurately described, the developer cannot be expected to investigate it, let alone fix it.

Didn’t read the first line of my reply, did you?

I only ever noticed it on the General Ledger Report because it was the only report of all the reports I print monthly that was longer than one page.
This month I printed out to a PDF file for convenience of sending to a back up drive and discovered it happened then too.
Since my first post I have gone through and tried printing my reports but over a longer time frame resulting in reports longer than one page and the blank page occurred on all the ones longer than one page.
That was when I tried the other computer (Vista) and then swapped physical printers…all with the same result.

Have you tried to reproduce the fault using a windows computer and a PDF writing program yet???

Yes, I did. But one person’s blank page is an empty piece of paper, while another’s includes repetition of headings, but no line-item content. Other users have reported both at various times in the past, although not with the General Ledger Transactions report specifically, and I was trying to clarify which situation you were experiencing.

No, because I don’t have such an installation available. I will note, however, that this problem (or ones like it) have only been reported on Windows machines. Now that you have described your problem more completely, you have reinforced my opinion that what you see is caused by your operating system. PDF generation using the PDF button is under Manager’s control. Direct printing and PDF generation by external “print-to-PDF” drivers and applications are not.