DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Unable to complete reconciliation process


#1

Hello. I can’t get Manager to complete a non-internet reconciliation.

I’m entering historic data to get started with manager and I’m ready to reconcile to 9 December 2013.

So I go to Bank accounts -> edit and tick internet banking is not available.

I enter the statement end date - 9/12/2013 and press ‘Update’.

I go back to the bank account list and click the reconcile button.

There it asks me to enter the balance at 9 December 2013. I enter the balance and press ‘Update’. But all that happens is the value box resets to ‘0.00’ and it asks me to enter the balance for a new (random) date - which is usually ‘18 November 0030’!

If I continue to enter values for each date Manager presents and press ‘Update’ the dates just keep changing with the value box resetting to ‘0’00’ each time. If I exit to the bank account screen the account still has a white reconcile button with the first, correct date, underneath it.

Anyone know how I can fix this loop and get the account to reconcile correctly?

With thanks.


#2

I’m not sure but have you checked you start date ?


#3

Thanks @itmoto for the suggestion. My start date looks right.

More worryingly - I get this same strange reconciliation behaviour if I roll back to an earlier backup.

I don’t know whether it’s related but in my previous accounts program you could enter dates in the format dd/mm/yy. I did this accidentally in manager a couple of times and notice the dates rendered as dd/mm/00yy. I think I’ve corrected all cases now - but might it be connected?

So I don’t know what to do - I really don’t want to enter all the data again, but my previous 2 backups don’t seem to solve this. If the data was held e.g. as mysql I could take a look at it which might help. But as it is I don’t recognise the format.

BTW I running Manager 14.10.2 on ubuntu 14.04 desktop. Thanks.


#4

Ok - found the problem.

It was that I had a transaction dated dd/mm/00YY. When I corrected that date the account in question automatically appeared as reconciled - clearly using the reconciliation value and dates entered previously.

The key takeway then is that Manager doesn’t do much sanity checking on dates and if you’re entering historic data using the date picker is long-winded. Be careful then to make sure the dates are correct. Manager will cheerful accept dates way out of any sensible range - especially two digit years which it converts to ‘00YY’.


#5

I had originally opened Manager and just added all transactions from the install date and all went well. I then decided to add historical data and found the same problem. I tried several things, found that I could not reconcile prior to the install date.

I then changed the computer date back to when I wanted the data to start from, Installed the latest version of Manager and then went through the process of entering all data from the start date. I added a month at a time and reconciled as I completed that months entries, then brought the computer date forward another month and completed the next months entries etc.

It was a long process, but it worked fine after that.


#6

I have just upgraded to 14.12.29 two days ago and now my reconciliation hangs after I input the last balance for the month and then press update button… Has anyone come across this?
I tried to install the previous version without uninstalling the new version but it wouldn’t allow…


#7

Please upgrade to the latest version (14.12.35). This was a regression bug.


#8

Lubos
Awesome mate, thanks for the quick reply…