Ubuntu 17.4.9 Update

Just updated from 17.3 to 17.4.9.
Installs ok. On start home screen shows ok showing correct accounts and paths to them. The program shuts down whenever and account is opened, or if an existing account is opened via the file explorer opening dialogue box.

Any thoughts?

I run Manager on Ubuntu also

I am having trouble visualizing what you are trying to describe

Can you say what you mean by “account” and “file explorer” please

The program opens. The home screen is displayed. Clicking to open an account shuts down the program

Can you start manager-accounting in your terminal and gave us the output if the error comes again?

I have the exact same situation. In terminal, if you try to start Manager with manager-accounting even with sudo does nothing. It just says command not found. I uninstalled the and reinstalled Manager and nothing. I tried to create a new business and tried to restore a backup and nothing happens. Manager just close itself. Please help or tell us what to do to fix this!

Is this happening in every business you open or just one particular one?

Can you create new business to test?

Just edited my post telling that I tried to create a new business and it doesn’t work. When you type the name of the new business and save it Manager close and there’s no new business, at least in my case. And it happens in every business.

I’m a little confused, but I can’t launch this version AT ALL (Linux Mint Cinnamon 17.3). My confusion stems from the fact that what I see in the folder looks like a Windows installation–full of DLLs. Has an error been made on this somewhere?


I did various tests. First, uninstalled Manager and then deleted the size, recent, core and libe_sqlite3.so files. Installed Manager again and it worked. Closed Manager and open it again for the same error. In this occasion Manager renamed all my businesses with the same name but with an (2) in the end. Also, in the /opt/manager-accounting file I noticed that the Manager exe is in fact, and .exe file and also I have a file named “ManagerServer.exe”. Started the server and from the browser I can see all businesses but can’t access to any of them. Uninstalled Manager again, installed it and I have the same issue.

Just to clarify one thing, are you using 32-bit or 64-bit Linux?

I don’t know the others but I’m using Ubuntu 16.04 64-bit.

I’m able to reproduce the issue. Looking into it.

Yesterday it works on my 3 pcs all Manjaro Linux 64 bit, today something wrong. NullReferenceException: Object reference not set to an instance of an object is my error on 2 machines, why?
Today i have have on my pc and wrote some invoices, i was ready and have saved it via Backup file, some minutes later my grafikcard is broken and i can´t use anything, so i must shut down my pc.

i open my laptop on evenig and make first the new update, then i will open one file from my drive folder and it give me that error. NullReferenceException: Object reference not set to an instance of an object
i downgrade to the old version 17.4.9 but nothing changes. i delete the manager folder in /.local/share nothing.
Ok i thing you start the other laptop, here the same error if i want to open one backup file from my drive.

so now i am very unhappy, nothing woks fine in this moment, my desktop pc is broken, i can´t write my invoices, i seems it is not my day, or not my week.
good evening. :frowning:

Might it be possible to post a link to a slightly older version that does run okay, for the time being, please? (Don’t want to appear impatient, but it’s kind of a crucial time just now in the U.S.A.!) Thanks!

@Metalsmith OK, try https://mngr.s3.amazonaws.com/17.3.20/Manager.deb

Thank you, Lubos! In addition to a scholar (and genius, needless to say…) you are truly a gentleman!

I have an older version testet 17.3.19 and on the laptop it works.

The latest version (17.4.17) should be fixing the issue on Linux.

Yes, this 17.4.17 does indeed seem to be working well, so thanks Lubos!
BTW, I’m trying it on ElementaryOS, a kind of slick, user-friendly (MacOS-like) Ubuntu-based Linux variant, and it runs fine on it!

The latest version 17.4.17 works fine for me, thx lubos.