Latest update for linux no longer working

just downloaded the latest update for Linux desktop and it no longer opens after install. I’m running Mint 18 can you possibly help me come up with a solution. Uninstalled and reinstalled , rebooted nothing seems to work. The icon acts like it will open but nothing happens.

Please search the forum, this has been discussed in several topics

Thanks for the reply but I already searched, tried all the suggestions nothing works. I’ll eventually get it figured out but thought someone within the last few days might have had the same problem.

Perhaps you would like to post your solution here, as it could be useful for others.

It may have something to do with the latest Mint update. Unfortunately I updated Mint and Manager at the same time. Duh… Going to try and revert to earlier version or incarnation of Mint and reinstall Manager to see if that works. If so I’ll keep you posted. Thanks again.

Did you find the mono references in the forum? Which mono version are you running?

Also, try this in terminal… it will force any dependency checks after install.

sudo dpkg -i /path/to/Manager.deb
Followed by sudo apt-get install -f

I updated to the latest mono version and still nothing works. Also opened one of my Linux virtual machines that had not been updated and installed the latest Manager version, it will not start either. Beginning to wonder if something in latest manager update is not gone wrong.

what is your mono version?
mono --version
in terminal.

What is your Manager version?
dpkg-deb -I Manager.deb
in terminal

Hi all,

Thanks for all the good work you do.

Having the same issue on Ubuntu 16.04. Manager version 16.12.39 and Mono version (says Mono JIT compiler version) 4.6.2.

Would appreciate any help.

This problem have been discussed about Ubuntu 16.04. Try navigating to /opt/manager-accounting in the terminal and once there do this: sudo ./manager-accounting. If this is your problem, then Manager will start. Close it and try to open it again without any command. If it works you will not have the problem again. It is something related to a file that Manager generate again during this process when you do the sudo ./manager-accounting in terminal. Please tell us if this solve your problem or how do you solve it finally for future reference or maybe for other people with the same issue. Good luck!

This is the post where @Gert explains this process: Manager does not start after recent update on Ubuntu

That did the trick. Thanks very much.

Tried the sudo ./manager-accounting suggestion in Mint Cinnamon and it works.Tried it in Mint XFCE and version 16.12.39 still does not work but version 16.5.13 works fine without doing the Sudo ./manager-accounting trick. At least in Linux Mint Cinnamon it seems to have fixed the problem.

Have you checked your mono version in XFCE?

You’re welcome, @Grodd. @kgeo1960, maybe I’m wrong but I guess this has something to do with the libe_sqlite3.so file. If I understood correctly in the thread I have mentioned above, I think this file have been change through the latest versions, so in the newest versions of Manager for Linux, the file is not updated when you install the latest version. @Gert found the trick to make the new version to recreate the file using sudo. @lubos also mentioned that he have little experience with making Debian packages in this same thread, so maybe this has something to do with the compile/packaging process of the .deb package because it is was not a dependency problem or mono version problem in my case. It was this file and once it was regenerated everything works again.