Version 19.7.0 linux: Crash on start up

Crash log

I’ve removed the .local/share/Manager folder but it still crashes.

Ubuntu 18.04.2 LTS

Try downgrading mono to 4.6.1 Stable.

I downgraded manager instead. I had an old Manager.deb file, v19.1.26, v19.6.63, v19.6.83 can start up without crashing.
But v19.7.0 crashes on start up even with no data.

Unfortunately, I can’t do anything with my existing data. It says the database is a different version or something. So I’m locked out.

Where are the old releases of this software?

First, Manager is backwards compatible, but not forward compatible. That’s because newer versions sometimes change the structure of the data file. So you cannot go backwards.

Second, older versions are not available publicly.

Ok, so I’m locked out of my data if I upgrade. I’ll keep a backup of the Manager.deb for next times.

But I figured it out, change the download link to the version number like…

Since V.19-7-0 and the latest V.19.7. Manager crashes on start up
Creating at Home Folder file: mono_crash.763cb9cac.2.json.
Version 19.6.82 running OK.

@GrManager2019, you need to furnish more information: operating system and version, edition (desktop, server, cloud), description of “crash” behavior, etc.

Thanks you’ here is additional information -
desktop version fail to start.

Crash reports attached.

Regards, Giora

(Attachment mono_crash.763cb9cac.0.json is missing)

(Attachment mono_crash.763cb9cac.1.json is missing)

(Attachment mono_crash.763cb9cac.2.json is missing)

Indeed, there is something wrong with version 19.7.0 (haven’t tried older versions). Fresh Ubuntu installation and it crashes. Haven’t you tested it properly?

@astandet, if you have problems, please provide detailed information. “Fresh…installation” and “it crashes” do not provide sufficient detail for troubleshooting.

Sure thing, here it is. Actually, it’s version 19.7.7. I run it in virtualbox, but it shouldn’t matter.

ProblemType: Crash
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Jul 10 17:39:56 2019
DistroRelease: Ubuntu 18.04
ExecutablePath: /opt/manager-accounting/ManagerDesktop.exe
ExecutableTimestamp: 1562735540
InterpreterPath: /usr/bin/mono-sgen
ProcCmdline: /usr/bin/cli /opt/manager-accounting/ManagerDesktop.exe
PATH=(custom, no user)
Description: On starting the program, the main window shows briefly, but stays empty, then disappears. Need more info, just ask.

This looks pretty broadly based. I am putting it into the bugs category.

Ubuntu 16.04 LTS
Intel® Core™ m3-6Y30 CPU @ 0.90GHz × 4

19.6.83 working as normal
Any version after opens with a blank white screen for 2/3 seconds then closes program.
Deleting home/.local/share/manager did not change situation.

The latest version (19.7.8) is fixed on Ubuntu.

Thank you

Thank you, I can confirm that V.19.7.8 is working on Linux Mint.