Trouble backing up manager file

I am using Manager desktop version 20.10.78 (?) I have not backed up since December. I followed the usual process to backup (Open Manager, select Business, select business name and select Backup at top right) but after selecting ‘save file’ I get an error message: System.IO.IOException: The process cannot access the file because it is being used by another process. I tried closing Manager down and opening it again but continue to get this message. I wanted to back up before downloading the latest version.

Your business file is stored in your application data directory. See Manage application data folder contents | Manager I suggest you go there and manually copy / back up the files.

After which update your Manager program and see if the problem persists.

Thanks, but sorry I cannot find the application folder. The info you pointed me to says that on the desktop edition, the application folder is found at the bottom left of the business page, but there is nothing at the bottom left. I shall try shutting down the computer and restarting everything and see if that does anything. Any further help is appreciated. Going away tomorrow and wanted to copy it onto a laptop, running out of time to figure this out.


You are too far behind for a lot of this forum to make any sense - update your version - 20.10.78 must be 300-400 versions out of date

Ok. I just wanted to backup prior to updating. And backing up is the issue here. I haven’t lost info before when updating so have to trust it will be the same this time…

Backup the folder where .manager files are stored and then update.

  • The Guide has been updated to reflect the current programs behaviour.

  • In older versions of Manager it did not show the path to the application data folder however it was in the same place.

  • The location depends on what operating system you are running Manager on and if you have set the path to something other than the default.

  • Search for “.manager” (without the quotes)

  • on Windows desktop it defaults to the hidden directory
    C:\Users<windows user profile name>\AppData\Local\Manager

I updated (without backing up) to see if that would resolve my problem and I couldn’t work out manually backing up. The data is all there and no longer getting the error message. Now when I choose backup, open folder to choose which folder to put it in and edit the file name (all as usual) and okay, it appears to backup, but when you look in the folder the icon beside the file name is a blank notepaper not the red M and I am unable to import the backup (I tried this on our laptop when away).

So the version I have now is 21.2.78.

Update your software. You are dozens of versions behind.

I found the data file in admin, appdata folder via windows (the Manager bottom left ‘application folder’ seems to only have the option “Change folder”). Then I copied it across to another folder as a backup. It is up to date data. Previous to this I somehow managed to have two manager files running at once with switching around between web forum and business accounts I was working on. On hovering over my bottom screen short cut, I realised 2 were open, I closed one off before realising it was the one with the most recent of todays work, but the app data file had the latest and thankfully it appears I haven’t lost the work I thought I had :slight_smile: Never had this problem before. Am I going crazy :smiley:

So on downloading the latest update just now, the backup problem seems to be fixed with all file icons showing correctly in my folder, no errors. To avoid this happening again the suggestion seems to be to not leave it so long between updates and is at least weekly ideal? I’m not a regular daily user and sometimes a couple of weeks or so will go by between uses.


There is no “ideal” update interval. The reason I suggested you update was that work is going on to improve the program’s infrastructure and several bug fixes have been made in recent weeks that repaired exactly the kind of problem you reported. Personally, I update at least every few days, but that is because I am a forum moderator. Many users find once per month adequate.

I just did a “backup” of Manager file. Here is a screenshot of what it looks like when I look into the folder where it saved. I thought the issue was fixed but maybe that was only because I searched for the appdata file as suggested and copied it across. The red M files are the backups from previous to this problem. The later ones are all since then. If I try to add the business from the backup file, it is an invalid file format.


  • The new version of Manager will only be able to read the new backups.

  • They are the ones with the red manager Icon, and extension .manager

  • In your screen shot that is the ones with a name containing “(2020-11-18)”

Most people would rename the Manager business to remove the back up date if that is the business file you are routinely using

No, the red Manager icon ones are the old backups (hence older dates on them).

The new backups are the more recent dates - with no icon and invalid file, including the backup with today’s date. The Manager version is from couple of weeks ago.

There is one recent red Manager icon for 2021-03-16 which I believe is the file I copied from app data, last time I was having trouble.

All the files with a date in the name eg Elouera Woodworks 1.7.16 (2020-11018) are backup files created by using the backup button in Manager

Are you importing your file each month and creating a new Business?

What you believe is happening is not consistent with my experience.

To illustrate. I created a test business called “Temp 3”. If I click on the white “Backup” button near the top of the screen, when in that business, I get this screen. Note:

  • the business name shown near the “Rename” button
  • The default name created by Manager
  • The file extension Manager will use

Clicking on the Blue “Backup” button then defaults to the same file name as the prior screen but allowing the backup directory to be chosen by the user. The file name and extension can also be changed (but this is not usually required.
Backup Save as

Looking in Windows then shows the file created. Note the file extension and icon

Yes I’ve been using the back up button as usual. Last month I wished to back the file up onto USB to use on a laptop while away, I downloaded the latest version onto the laptop however was unable to Add Business and use the file, as it was invalid. (I also downloaded the latest version onto my main PC prior to this to try to fix the problem). I normally only backup before downloading the latest update and then continue to use my Manager file as usual on my main PC.

OK, just wondering why you have a backup of a backup of a backup

If that is true you are currently not backing up correctly. Now if done correctly every Manager backup file as the file extension .manager