Single Touch Payroll (STP) Worksheet not populating all data

I am using the current latest version of (, and for some reason, some of the fields in the STP worksheet won’t populate. In particular:

  • Entity ABN
  • Employee TFN
  • Date of birth
  • Basis of employment code
    I have checked the fields in Employees (and in Settings → Business Details) and they are populated there, but for some reason the STP Worksheet won’t pick them up. The fields are blank, and so are the fields in the CSV dump. I have tried all sorts of things such as clearing out Entity ABN, then going back in and putting the data back in. I have also tried creating new employees and re-generating the STP worksheet, as well as trying a new payslip. Any help much appreciated.

It works for me, I tested Manager Windows x64 v23.1.20.597

  • my normal business file
  • A new test business created just to test it.

Please provide more details of what you are entering and seeing

Thanks for the reply, Patch. Please see the following screenshots showing test employee details, payslip, and the STP worksheet. You can see I have the TFN, DOB, Payment Basis entered in the employee details, but they aren’t appearing in the STP worksheet.
Many Thanks.

I’m running Windows 10 64 bit relatively current however I have not allow Microsoft Edge Webview2 to update for awhile.
What operating system are you running?

I am running Windows 11 x64. But I also just tried it on Windows 10 using the same company file, but have the same problem. (I also just tried installing an older version to see if any different, but this older version won’t let me open the company file as it detects that it has been last opened by a newer version).

@nevoz are you sure you only have one and only one Jane Doe defined as Employee?

@Ealfardan yes, absolutely just the one Jane Doe.

I don’t know if this may somehow lead to the cause … prior to having this latest version, I was using quite an old version (21.6.33). It only supported STP Phase 1. I then upgraded to the latest version (, and it automatically upgraded to the STP Phase 2 worksheet. Could I have skipped too many versions, and this has somehow caused an issue? Note, I have since (ie after upgrading) deleted the employee, payslip, worksheet to re-do them from scratch, but the fields were still missing. Note also that the “Entity ABN” is also missing, I’m assuming this is meant to populate it from Settings → Business Details.

Please show some screenshots in search of Jane Doe in the Employee tab.

That’s possible, in that case, one issue comes to mind and that’s the Custom Fields UUIDs are not identical for some reason.

To test this, please provide the UUIDs of the missing Custom Fields and I will compare them against the localization file.

The UUIDs can be found in top right corner of the edit screen:

To isolate the problem, I’ve deleted another employee so just the Jane Doe one is there. I have also added a fake email address in case the absence of that was somehow causing the issue. It didn’t help.
See below for the screenshot you requested, showing Jane Doe as the only employee.
Jane Doe Employee UUID: 37e86be9-e63c-4a37-98ac-ca5d4fe78314
STP Worksheet UUID: abfc575a-eeb2-4e63-9a06-e50ed199d013
Many Thanks.


  • create a new test business
  • add businesses details
  • add an employee
  • add a payslip
  • add a STP report

The above procedure worked for me.
Doing so separates businesses file issues from program code / operating system issues.

I just tried a new test business, and it worked perfectly fine. So there must be some issue with the file I guess … any further ideas with getting it to work?
Many Thanks.

I have just tried deleting all employees, payslips, payslip items, related super liability & wage expense accounts, STP worksheet … and recreating it all. Unfortunately still no good… :expressionless:

Does this mean that no custom fields exist for Employee?

Oh sorry I misunderstood. Looking under Settings → Custom Fields → Classic Custom Fields, there are a number of them there. Funnily enough, none of these appear in the working test business, only in the real business file. See screenshot below. I don’t think I created these custom fields myself manually (except the last three entries shown in the screenshot, I probably did years ago).

  • ABN: 0fba87ee-0386-401a-8d1f-302313b663f4
  • Tax File Number (TFN) : 8067ce2d-6a48-45f1-a5a9-5e2d923e9cc7
  • Date of Birth : f6859bbb-1736-4e60-81f2-2703a9ea4686
  • Payment Basis : 6b837666-1039-4cfc-948b-5c36b30682c2
    Considering the working test business file doesn’t have these entries, should I try deleting them from the real business file?

Localization fields used to be Custom Fields in earlier versions but now they’re not.

So, if you could take a backup and try the following:

  1. unselect Australia from Business Details,
  2. delete duplicate Custom Fields, and then
  3. re-select Australia and test again

See if it works then

@nevoz those Classic Custom Fields should be deleted. Upgrade script should have deleted them as they are no longer relevant or used.

Thanks @Ealfardan & @lubos , that has now fixed it…!

Is it possible the upgrade script was removed from later versions? I had skipped straight from a very old version (around 2 yrs old) to the latest one.

1 Like