RPM package

I wanted to try this program on Fedora, but it does not have a RPM package, i unpackaged the DEB and it didnt quite run even with mono-complete, so i installed mono-tools which includes:
Install mono-tools-3.10-3.fc23.x86_64 @fedora
Install svgalib-1.9.25-18.fc23.x86_64 @fedora
Install webkit-sharp-0.3-16.fc23.x86_64 @fedora
Install links-1:2.12-1.fc23.x86_64 @updates

And ran it with mono filename.exe and it runs fine, converting the .deb to .rpm however doesnt seem to quite work as it throws this error:

Error: nothing provides mono(Eto.Mac) = 2.1.0.0 needed by manager-accounting-16.1.78-2.noarch

That dependency needs to be changed to be equal or greater than.

Eto.Mac shouldn’t be a dependency under Linux. This assembly is used on Mac OS X only.

How do you try to convert .deb to .rpm ? Shouldn’t it be easier to create RPM package from scratch rather than by converting?

All I had to do to get Manager running on Fedora 23 was:

  1. extract .deb package to a temporary folder ( /home is fine )
  2. move the files to their respective folders
  3. install mono-tools ( in terminal: sudo dnf install mono-tools )
  4. Link /usr/bin/mono to /usr/bin/cli by running command in terminial: sudo ln -sf /usr/bin/mono /usr/bin/cli

Then just launched Manager normally and everything worked. I also tried this in openSuse and it works as well. Hope this helps.

I have been maintaining a rpm for Fedora (for my my own use) for a while now. If you or anyone in the community wishes to use it I have uploaded both the rpm and src.rpm to my Google Drive account. Both the rpms are signed and my public key is uploaded to the folder. See here:

https://drive.google.com/open?id=0B_SJ4cta4MaYU3dEbEc3V3ZYQ00

Thank you for this software, I greatly appreciate all the hard work you have put into your product. As yet I have found nothing else comparable under linux. I would be happy to contribute by regularly packaging up your releases for fedora. Let me know if your interested.

@agrez, the latest version of RPM package should be always available from http://download.manager.io/Manager.rpm and source package is at http://download.manager.io/Manager.src.rpm

Could you please test?

Yep, it works! I found a small issue. Will message you about it.