Ubuntu v18 Bionic Beaver



Ubuntu 18 LTS will be released in April. I’ve installed the beta release and find that installing Manager is not possible, as per previous threads. However the solution that worked before does not work now.

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install -y mono-complete
sudo dpkg -i Manager.deb

When I’ve struggled in the past with the built in installer, installing Gdebi has installed it- but not on this occasion.
Any help out there??



I would add that, I would be very happy having Manager in form of AppImage as this would solve a lot of problems (single package for ALL linux versions and distros, no debs, rpms, tgz etc.). Manager is the only which is keeping me away from using Arch/Manjaro as AUR repositories contain outdated (17.4.*) version, I was trying to manually install dependencies (to get newer version of Manager), so had to compile libwebkit. That took entire night and at the end I could not run because of other unsatisfied (or broken - do not remember) dependency, but I just had no time to compile another one and quit.
Currently I am on Debian testing and it is able to install *.deb files with dependencies, debian unstable does not provide libwekit (because too old or unsecure?!), so I had to install manually. Everything went fine, but still - spent time searching, digging, downloading and installing.

AppImage is single self contained file with all required dependencies, it doesn’t interact with system files, so there will be no broken dependencies (with testing purposes I was successfully able to run QT5 Skrooge package on Gobolinux (3xy kernel, AwesomeWM, restructured system layout!!!) and no problems running and working. I highly recommend AppImage, it is easy to pack and does not require subsystem module to be installed and (like snaps & flatpacks).


I installed Manager on the latest downloadable iso from Ubuntu and was surprised that going trough the installation process via the GUI (Ubuntu software center) was successful. It pulled all the necessary dependencies.

Can this be replicated in ubuntu18?

+1 on the AppImage idea.


You must try to install Gdebi on any Ubuntu distro first. After installing Gdebi you can try to download needed version of Manager or install direct from Ubuntu software center. Your software installer can be damaged. Reinstall installer:

sudo apt-get install gdebi


Hi, Gediminas

Thanks for the advice. I’ve already installed Gdebi and failed with it.
Kind regards



Hi Martyn,

Which version of Mono (cross platform software) you use? Try to install without -y in installation command. Remove installed Mono application if it not help you. Also remove all associated extensions and libraries Try to install Mono. Ubuntu and Debian have some problems according Mono.


I am forking my post re AppImage as separate idea :wink:


Thanks for further advice.
I uninstalled Mono then reinstalled via

sudo apt-key adv --keyserver hkp:// --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo “deb stable-xenial main” | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt-get update
I then installed mono-complete after sudo apt-get install -f

when trying to install Manager I got libgtk2.0-cil-dev and libwebkit1.1-cil not installed.
Managed to install libgtk2.0-cil-dev but libwebkit1.1-cil appears to be obsolete.




Some packages and libraries are not included into basic Ubuntu distribution. So, you you should install manually. Many important libraries are in the webkitgtk2. Manager installation is impossible if you not have updated all libraries and packages. Follow info in the terminal. Terminal will show all missing components. I had a same problems with Ubuntu and Debian. Every time after the system upgrade I had to reinstall some libraries. It is very uncomfortable. I tried to install it in various Linux distributions and finally i chose Arch based OS. They are the most advanced and do not have same bugs as Ubuntu.


By end of this month, there will be new packages for Ubuntu and Fedora which should be referencing newer dependencies. As it stands now, current packages of Manager don’t work on the latest Fedora and probably stop working on upcoming Ubuntu. So that is being addressed.


Good news Lubos. It should help for many users.


Great news!

Thanks Gediminas