Print as pdf and pdf are totally different

Hi, I downloaded the v22.3.46 for mac.
the Print button changes the format completely as compared to PDF button
Can this be resolved

Can you demonstrate with a screenshot? Also, going onwards, you should use Print button which contains function to “print to PDF”


SS2.jpg file shows when i select “print” and “save as pdf”
SS3.jpg file shows when i click on pdf

When printing, there should be Print backgrounds checkbox in print dialog.

1 Like


This is the print dialog box that opens in mac os.

Try clicking on Media & Quality dropdown to see what other options are there. This could reveal Print backgrounds checkbox underneath.



This is all i get

I can replicate this, the PDF properly puts the logo to the right but the print preview in macOS (different browsers) all put the logo more to the middle same as with the screenshots of @bharatkk. For me this is not an issue because I use the legacy PDF generator which also allows me to use the email function of Manager.

Mine did the same. It is in the coding for the custom theme. I can’t remember which lines I had to copy over from the plain theme but it was in the first few. I used winmerge to compare and then experimented.
Sorry I cant be clearer but hope it helps.

Confirming I get the same issue as shown by @bharatkk, with the logo shifted towards the top centre of the page, when printing using the Print button (Manager v22.3.47). However, I am using a custom theme (a simple adaptation of the standard theme to add a footer), and the problem goes away when the custom theme is unselected. Nonetheless, this change in behaviour has emerged since a few versions ago. I am on Windows 11.

I can replicate the displacement of the logo on macOS. It is behavior that appeared at least as early as v22.3.34. It occurs only with custom themes. The problem seems to be related to changes in the style definition for display of the business logo. The code in the Plain theme has changed. The old Plain theme included this line:

{% if business.logo != null %}<td style="text-align: right"><img src="{{ business.logo }}" style="max-height: 150px; max-width: 300px" /></td>{% endif %}`

The new Plain theme substitutes this line:

{% if business.logo != null %}<td style="text-align: end"><img src="{{ business.logo }}" style="max-height: 150px; max-width: 300px; display: inline" /></td>{% endif %}

In my tests, making the same substitution into custom themes resolved the problem. But that may depend on what else you have changed or added in your custom theme. (I only tested two.) I am moving this topic to bugs so @lubos can determine whether other changes may also cause problems.

The bottom line seems to be that the Plain theme had to be changed to accommodate alterations made elsewhere. Only if we know what those alterations were can we be sure we’ve revised all necessary aspects of our custom themes.

2 Likes

I’m still using 22.3.17 and the issue is there. It wasn’t there from memory in 22.3.3.

I made the change in the custom theme for the text-align: right to text-align: end, but it made no difference.

{{ title }}
                {% if business.logo != null %}<td style="text-align: end"><img src="{{ business.logo }}" style="max-height: 150px; max-width: 300px"></td>{% endif %}
            </tr></table>

I copied the code from plain theme to my custom theme and it worked.

But now how do i get the background color for the receipient block and table column headers.

This is how it is supposed to look

See post in this discussion by @Lubos where he explains that you need to enable “background”.

There isnt any option for enabling backgrounds in the print dialog box.
Screenshots were attached.
i guess we just moved onto the logo location after that.

You did not click on Media & Quality as @Lubos suggested. Your screenshot shows that you have Layout checked, click on Media & Quality and the screen will change and enable background will show up.


this is with media & quality selected.
print/enable background doesn’t show up

enable background shows up in “safari”
but the print dialog box that manager opens up, it doesnt show

It seems like this isn’t something that’s related to Manager, more like a recent change to chromium browsers or a w3 standard or something.

Anyway, to correct this add the following attribute to the style of the img tag:

  • display: inline-block

That will do the job.

I did not say to make only that change. I said to substitute the entire line.

1 Like