Order field on sales invoice form

Previous versions of Manager had two Order number fields.

  • First one that you could use to enter any text
  • Second one that you could use to select actual sales order from Sales Orders tab

To reduce number of fields on invoice form, the first Order number field has been removed.

To move forward, you have two options.

Option 1: Use “Sales Orders” tab

This has number of benefits. When you create sales order in Manager, you can track whether orders received from customers have been fully delivered and invoiced.

See: Monitor sales order status | Manager

Option 2: Create custom field

If you don’t want overhead of Sales Orders tab. You can still keep everything as simple as before.

Go to Settings tab.


Then Custom Fields


And under Sales Invoice section, click New Custom Field.


Fill out the form like this:

Then click Create button.

Now when creating new sales invoice, you will see your new custom field at the bottom in Custom Fields section.


When you view the invoice, you will see the content of your custom field Order number at the top of the invoice like before.


You can create more custom fields as you desire or even rename Order number field to something more appropriate.



Thanks for the update however, this one still has a problem with me.
Before, there was ‘order number’ column in ‘sales invoice’ tab so I’ve always been looking for my invoice searching by order number. Now I cannot do this as even if I create custom field, the field isn’t showing up in ‘sales invoice’ tab so it’s useless. I need it displayed in the ‘sales invoice’ tab all the time. Thanks.



If you wish to show Order number as column, then in custom field form (when setting up custom field), also check this checkbox:

  • Show custom field as a column


Thanks but can this be merged with the exising order number column or at least before the description?
It’s currently after the discription and it looks untidy… I want all these kind of referencing numbers shown before the job description column. Thanks.

Do a once off Batch update, see Use Batch Create and Batch Update functions

Most government departments and mining companies (large organizations) will not pay you unless you quote their order number in the invoice. Can’t we just have it back please?

@BertChris, the opening post in this thread tells you two ways to include the sales order number on sales invoices. You seem to be making the same mistake several other forum members have, believing for some reason the ability is gone. It is not.


No I am aware of the work around and the fact that I now have to edit the custom theme so that the order number appears on the invoices the same position as it previously was displayed.

The amount of extra work required by myself and other users is frustrating for something that has always been there and used by so many.

That is not required anymore. See the beginning of this topic how it’s done without any coding.

I agre!! This change has made things more complicated for all the users that have used the Order Number as it was before. The main issue is that as @chris.chai explained there will be two columns on a screen view that is already very busy, and doing the batch updated can be tricky on so many invoices done during so many years.

Why can’t the order number be left there for those who used is as it was? I really do not get this, sorry!


Columns are only shown it the field contains data. That’s why you

The real issue is that the two order number fields on the Sales Invoice should never have existed in the first instance and was a recipe for disaster. Those that use Order numbers would be encouraged to first create a Sales Order and then copy to Sales Invoice, etc. Those that do not want to create Sales Orders first can use option 2 and use Custom Fields.

I found another hassel with this update is that even if I tick ‘shaw at the top of printed documents’ when I actually input all the data, because it’s now in custom field, I have to put the order number at the end and because it’s not showing it on the top when inputting data, all my staff miss putting it and just create and send emails.

This is not definitely an update feature. It should’ve been developped to use the original order number field as manual or to sync with ‘sales orders’ tab. I believe there’s a way to do this rather than just removing and using “custom field”

I’m trying to do the batch update, if you show all invoices and copy them to Excel with:

You have the columns as in this view:

However, if you follow the batch update and click copy to clipboard, it copies in customer data seems like to me:

Is this correct? How would I update the new column (Custom field) Order number over from the old one if it does not give the correct fields?
I’m sure this will mess up everything and I will have to restore the backup taken before. I’m hesitant to even attempt it.

In Manager do not go straight to copy to clipboard

  1. In Manager → Sales Invoice → Click on “Batch update” (bottom right corner of the screen)
  2. Then click on “Copy to clipboard”
  3. Go to your spreadsheet and choose paste. This should result in tabulated data with columns for each field
  4. Update / move the old field data to the new field. Probably the easiest way of doing that is to sort by destination field then sort by source field. A block cut and paste can then be done without risk of over writing data. Sorting in the reverse sequence can then be used to show records where both fields have been used.
  5. Copy the data in your spreadsheet
  6. Go back to Manager and Paste back into the batch update screen

Added details to step 4.

1 Like

@Patch doing a batch update on thousands of invoices (and delivery notes and I do not know what more) is not exactly something I feel comfortable doing! This is why there will be two columns, one with the old Order Numbers and one with the new field which we need to appear in order to do searches.

@eko This is not the optimal solution for companies like ours where we do not want to lose time with Sales Orders and need things as the were before because of the reasons mentioned above.

@chris.chai I totally agree with you

In the screenshot you can see the column IssueDate, there is not only issue date info in that column. Same with all the others. How can I trust the correct data even if I only update one column and import it back?