Older version invalid backup if update

Hi to everyone i run 16.1.4 version in mac and in windows i tried to update to the latest version but the backup don’t open please some help

You updated by thousands of versions. What is the extension on your backup files?

@lubos may need to intervene to reformat your files.

the extension is .manager

Then your business should be already present when launching Manager. Why are you trying to open a backup?

Please describe in detail the exact steps you are taking.

I download the latest version then i installed it and my businesses was empty
tried to add the backup i have but invalid file error

Can you post a screen shot of the error message?

If you send me your file to lubos@manager.io I will send you back converted version.

I will make some online conversion service from these old versions so then it can be self-service.

ok i will send it thank you very much!!!

Sorry - have the same error - failed to update over several years, then didn’t have time to deal with it when it failed. (so just have been hobbling along by reloading old version again) My old version is 16.1.2
Have you had a chance to create an online conversion tool yet or can you convert mine manually?

There have been several threads about updating old files. You will have to do it in stages, including installing v20.9.89 from Github. That was the last version with conversion capability to the current SQLite structure. Use the version number as your search criterion and you will see all the forum topics about this.

1 Like

Thanks for your reply. I did update to v20.9.89 and it installed without errors but didn’t seem to convert the existing company data correctly. Garbled the names into hexidecimal code, that were originally v16.1.2 manager files. No worries.
So for others that get stuck here, just simply go to the next step and click “Add Business” then select “Import Business” and select your latest backup (But before you import it, make another copy of your latest backup to another folder just in case)
v20.9.89 imported my company file just fine and opened the data correctly. Even deleted the garbled file names when I clicked back on Businesses. Just need to update to latest version now after backing up again… Thanks again Tut.