Manager 20.9.89 conversion error


I am trying to convert my business database using the instructions that advised to download Manager 20.9.89 to open my new database. But once I install this version…I get an OUTDATED VERSION MESSAGE.

Welcom to the forum @ramirezandujar

This is because you already tried to open this particular file in a newer version. The newer version runs an update script to the data file making it incompatible with previous versions.

You need to get a file that wasn’t opened by a newer version and it should work.

Upgrade back to the latest version. If your business database cannot be imported into the latest version, send it to and I will help with that.


Lubos, no luck. Just sent you the database via email. Thanks in advance

Hi I think I have the same problem. Background - I had an older Mac and did a Time Machine full backup. The old Mac is gone and have new Mac (v12.6). I tried copying the backup application to new Mac but had to upgrade the Manager app. But after I did that only the biz name shows and no files/accounts inside. Tried installing a older version of manager and I get this screenshot.

Also got this screenshot

I have backups of Manager io but did the stupid mistake of not backing up the biz itself. I also tried looking for the database file but have no idea which it is -

Is it possible to extract the database and “put/link” it to a new version of Manager? Basically how do I retrieve my database? it must be in the backup somewhere right?


see Restoring data issue - #2 by Patch
You have to open the Manager data file in Manager v20.9.89 then in a later version.

  • Old datafile from very old version of Manager
  • Open datafile in v20.9.89 → works
  • Open datafile in current version → works

Note if you do it in the reverse order you get multiple reported errors:

  • Old datafile from very old version of Manager
  • Open datafile in recent version → Not sql database error
  • Open datafile in v20.9.89 → Datafile is from a more recent version Manager error
  • Open datafile in current version → now should work
1 Like

Also be aware your data files are hidden under macOS. Read the Guide about application data folder management.

SO I managed to use a different Mac to re-install my backup. I was able to recover my accounting and did a backup from within Manager and saved the file. The backup file has name EARTHYS (2023-02-09).manager. Now on my own Mac I installed 20.9.89 and tried to open the backup file by Add Business but it said the version of Manager needs to be updated. So I installed the newest Manager and tried to Add Business backup but I got the screenshot below. What should I do? Why does the backup from within Manager have problems opening?

Problem solved. I removed both the businesses and renamed the backup file and then imported and it worked! Phew…