Can't import old version backups

Backed up businesses before updating to a the newest version from very old version(dont remember the version number). Lost all businesses due to the update(updated as explained in the guides) and i can’t import the old backups. I tried following this: Import old database But in converts the backup.zip to .manager files with default values (000000000000000000000000000.manager). Help would be much appreciated.

1 Like

The link you referenced has nothing to do with how to update or import backups. It was about a problem a specific user encountered. Have you followed the Guide about how to import backups?

If that doesn’t answer your questions, you need to furnish more details. What edition (desktop or cloud)? Did you ever change the location of the application data folder? Have you examined the content of the application data folder?

The specific file you mentioned is the index. Read the Guide about managing the content of the application data folder.

If you can send me your backup files to lubos@manager.io, I will have a look.

1 Like

I am using the desktop version and i updated to the latest one, followed all the guides but the backups are from such an old version using the .zip extention that it wont import(invalid format or something). Didn’t change any location, just updated the desktop version to the newest version and lost all data in the process.

Sent you the backup files, hopefully you can restore them.

Breathe easy, @Astrid_Post. Based on what you’ve said, you updated from a really old version. But Manager has always been designed to preserve data. So as long as you have the backups, data is recoverable. @lubos will be able to sort this out and convert to a usable form. For future reference, you should be updating more frequently. Manager advances very rapidly, so you will have trouble recognizing many aspects of the program.

I recommend creating a test business for the learning process. Make a bunch of typical (for you) entries and explore what happens. Read the Guides, which address and give examples from the current version.

Yea lubos helped so i am very happy it all worked out. Will keep updating it regularly from now on!