No calculation for tax codes

After updating to latest version from 16.4.95 build in tax codes (greece) are not calculated in the invoices - custom codes seem to be working fine.
I have purchased the server edition and honestly I have no idea what to do.
I have successfully revert back to the old version but should I update in the future or not???

Please help

Could you post some screenshots from the latest version to demonstrate the issue?


I am seeing the same, where the tax column no longer appears on the invoice showing which tax code has been applied to a particular line item on the invoice.

Not sure if there is a new toggle somewhere that turns this tax column on/off.

I assume the tax code is custom tax code, right?

Could you go to Settings, then Tax Codes, edit your custom tax code and show screenshot of it?

when you edit the invoice the tax column and drop down box is there to select but the in build tax codes seems not to be working. The custom codes if you try seems to be ok after you update the tax % from settings - the built in tax codes no way

my main concern is with the invoices that they use built in tax codes because you cannot manipulate or update the %

But I’m not convinced it’s the in-built tax code that is causing the issue. Could you show in the latest version the screen which lists your tax codes under Settings tab? Then click Edit on tax code which is 24% and show screenshot of that screen too.

Attached is the screen shot of the tax codes in the setting tab,
followed by an invoice that was printed on the 8th Aug 2016
followed by the same invoice printed today 22ns Aug 2016
(current version of Manager is 16.8.54, sorry I cant tell you previous version number but I downloaded on the 5 August 2016).

@PhilD, this is different issue from @allexpapjim . Your issue is that Tax column doesn’t show. Can you upgrade to the latest version 16.8.70? The reason is that I’m not able to reproduce your issue in the latest version so try to upgrade first.

Sorry my misunderstanding.
Thanks Lubos, will upgrade now :+1:

So now using 16.8.70 and still having same tax column issue as described above.

Is there an easy way to break this into a new thread so not to confuse @allexpapjim issue.?

Works fine with built-in Tax Codes. See screenshot

On the other hand does not work with Custom Tax Codes (17%). I had to go to Tax Codes and edit again the code (the Custom Code shows 0%). Had only 2 options: 0 and 100. Selecting the Custom Rate gives you the option to enter the rate manually.

I think this happened after @lubos Flat Rate addition.

Yes, you are right. I actually realized the error and fixed that for users who will upgrade from now on so custom tax codes gracefully roll-over rather than switching to 0% rate.

I updated all the tax codes to the equivalent percentage and seems to work like a charm.

Thank you for your assistance Lubos you are the man