Invoices not saying Tax Invoice

I have created a new company, and the Sales Invoices are not saying Tax Invoice. I have set the Tax Code to New Zealand GST. Am I missing a step somewhere? My previous company seem correct.

Hi, my dodgy workaround is go to Settings, View Templates and then make a new template. On line 4, replace:

 <td style="font-size: 36px; font-weight: bold; vertical-align: top; line-height: 36px">{{ strings.invoice }}</td>


<td style="font-size: 36px; font-weight: bold; vertical-align: top; line-height: 36px">TAX INVOICE</td>

Simple and probably not “correct” but it works (it also give you an intro to how templates work)… Use this new template for your invoices.

All the best.

Thanks for that. I tweaked it a bit and it works well. It would be interesting to know why the word “Tax” is not showing correctly though.

The latest version (15.1.88) will automatically show Tax Invoice if you use New Zealand GST code. No need to edit template.

Thanks. That has fixed it.

I have select Tax Codes > Malaysia GST. But my Sales Invoice title not automatically change to Tax Invoice. How to make this work?

@hizamyusri, fixed in the latest version (15.2.7)

Thanks for replying lubos. Still not fixed. I updated to 15.2.12 the latest version.

Are you using in-built GST code or did you create custom one? This will only work if you use in-built GST code.

Yup. Im using in-built Malaysia GST 6%

When I try it, it works fine. If you like, send your accounting file to and I’ll have a look.

1 Like

Emailed to you sir

Can u share with me the setting… I also use Malaysia GST 6%

Settings > Tax Codes > New Tax Code > Malaysia - GST 6%

Dear Tut,

Thanks for the reply. I had choosed that setting but still did not appear the Tax Invoice.

my version is 16.2.11

Do you have a custom sales invoice view template, or are you using the default template?

I’m using the default template sir…

Your version is recent enough. (This bug was reported to be fixed at version 15.2.7.) I don’t personally use that tax code, so I cannot help you. Are other Malaysian users still having this problem?

looks like @hizamyusri facing the same problem with me. Waiting Mr @lubos to reply on this. Btw TQ for your reply.

Hi… I managed to resolve it. TQVM