Missing the blue set as default button

I have a problem when i try to create default note on my sale invoice.
I created a custom field named “note” on the sale invoice tab, then ticked “show custom field on printed document”.
When I create a new sale invoice the note section regularly appear and i can type in it everything I want (in my case my bank details).
And I have to type the note everytime I create a new invoice as the blue button “set as default” is missing, which is pretty annoying.
What did I do wrong?

Go to Settings > Form Defaults > Sales Invoices and enter the bank details in the “Note” custom field there.

If i go to settings-form defaults-sale invoice
it appear like a sale invoice sample with invoice date, due date invoice number…
Then customer where i can choose one of my client.

I can’t see any “note” field.

You need to update your software. Your version is many, many versions obsolete. In the version you had, the method was to select a customer, after which the entire form would appear. You would enter your default content in the custom field, then delete the customer. In the current version, the entire form appears at once, and no customer selection is required.

I just downloaded 3 months ago. I donwloaded again but nothing changed.
I am using linux, could it be a problem with the OS instead?

If I go on support page the version on the bottom is 18.7.0

If you are on version 18.7.0, you have the capability. It cannot be disabled. You must not be looking in the right place. Did you read this Guide: Manager Cloud?

I checked every guide possible and everywhere in the forum.

I fixed the problem anyway deleting everything and start again with a clean installation.
Now it seems to work absolutely fine. I probably messed up with something.

Thank you very much for the help and support.
Great software, great developers and great community!