Manager will not record US Dollars with decimal point

Every time I write a journal entry it changes to UK or Euro type figures such as this:

113.66 US get recorded as 11,366. I have changed the currency to US dollars, and I have also selected that currency in each entry on the right of the journal entry page but it still changes the currency to display and records in in Euro or pound format.

This software is worthless unless I can get it to record US dollars correctly.

What am I missing?

No, it’s not worthless. Set your number and date format under Preferences in the top menu bar. You can read about this in the Guides at You will also find much other useful information in the Guides.

I did that. It still records a foreign currency amount.

If I go back and edit the entry multiple times it will eventually record it
in US dollars, but for this to happen at all has to be a bug.

Thank you for your reply. And I did not say the software was worthless. I
said it was worthless to me if this isn’t going to record my journal
entries in US dollars.

I went to preferences as the guide instructed. Changed it to US Dollars. It still will not recognize the decimal point as a divider between US dollars and cents.

It is not clear what entry you are editing multiple times. Can you be more specific, please?

Use of US dollars is set under Settings >> Base Currency. After selecting your currency, be sure to click Update, or the program will not record the change. Normally, unless you have an unusual entry in a foreign currency, you should leave the Currency field on the journal entry with its gray default entry. If all your business is in US dollars, you need only set it once under Base Currency. No other entry will every require you to do anything with currencies.

This is not possible. Preferences only allows you to control decimal and date formats, language, and sharing of data. What were you referring to when you wrote this?

Decimal and date format. Not US Dollars. Sorry, my mistake.

I am saving after every journal entry edit and then check to see what it
has recorded. It is almost always in a foreign currency format that changes
the figures to those I have explained in my initial post.

If I go back to edit several times and click save after each time,
eventually it will record correctly. It is not doing so for the initial

Deep breath, everybody…

@DigitalServices, exactly what do you mean by “113.66 US get recorded as 11,366”? Are you putting in one hundred thirteen decimal sixty-six and somehow it’s being changed to eleven thousand three hundred sixty-six? Or do you mean something else? I agree that if software changes 113 to 11,300 then it would be pretty useless, but I can’t even come close to imagining that that’s really what’s going on here.

Can you perhaps demonstrate the issue through screenshots and a step-by-step account of how you reproduce the behaviour? Please also include screenshots of Manager’s Preferences > Date and number format screen, your business’s Settings > Base currency screen, and your operating system’s Regional Preferences settings for numbers and currency (under Windows: Control Panel > Region and Language > Formats > Additional Settings > Numbers and ... > Additional Settings > Currency).

@DigitalServices, show screenshots of following:

  • What you see under Preferences tab (so we can determine your number format)
  • How do you enter amounts in journal entry (which you claim will not be properly recorded once you click Create button)

I mean the second sentence in your reply. That is exactly what is happening. Here is a screen shot of a purchase I just made on e-bay to upgrade a company machine with 8 GB of RAM. Who is going to pay $3,384 for 8GB of new RAM??? The cost was $33.84!

Can you post screenshot how did you enter $33.84 just before hitting Create button?

Two points, @DigitalServices:

  1. You should not be using Journal Entries tab to record purchases. These must be done under the Cash Accounts tab, using the Spend Money feature.

  2. Even if you could enter monetary transactions under Journal Entries tab, your screen shot shows an unbalanced entry. That is, debits do not match credits. So this transaction will end up in Suspense until corrected. But even if balanced, such a journal entry will never be able to credit a cash account in Manager. And in double-entry accounting, a purchase like you have illustrated needs to debit an expense account and credit an asset account (usually a cash or bank account).

You might want to read the Guides having to do with Cashbook.

I entered it just as you did. 33.84, then update. I just tried it twice more and still it saves it as $3,384.

Can you show screenshot how exactly was 33.84 entered (before pressing Create button)? Also screenshot what you see under Preferences tab.

If you don’t do this, I can’t help you.

I think I just need to hire an accountant. Thank you for your replies.

All I have done here is enter the amount in US format. I have not pressed the Update button.

Why is it still placing a comma when it should be placing a decimal for US currency???

It seems like your decimal separator is comma, not dot. So you should enter 33,84, not 33.84.

This is why you should have shown screenshot of your Preferences tab which would reveal this issue in the beginning.

I can see that it’s comma. It’s supposed to be a period or decimal. I am entering a period when entering numbers.

The preferences tab has English selected as the language and English, United States selected for Date & Number format.

I just don’t know how to make it any clearer than this. Your software is not recording US format when it is being entered.

This can also be related to your preferences in your web browser.

What’s your operating system? It seems like you have some wrong settings outside of Manager. By default, US culture will ship with . (dot) as decimal separator unless user overrides that in their operating system.

This is a US formatted computer. A Lenovo T520 running Windows 7 Pro 64. Date, time, currency, temperature, is all US format.