DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Amounts on invoices and quotes round to zero decimals


#1

I have a problem on sales invoices and sales quotes where it is and rounding up and rounding down the costs i enter. For example £5.25 becomes £5 and £5.50 becomes £6 with a total of £11 rather than £10.75.


#2

It looks like your computer’s currency is set to zero decimal places (this is actually correct in some countries like Japan)

Can you go to Preferences tab and tell me what country you have set in Date and number format field?


#3

I moved 3 posts to a new topic: Making multiple invoices equal original expense


#6

I have it set to English (United Kingdom) and I also have Amounts are tax inclusive ticked.


#7

Does this happen to you across the whole system? For example, try to create journal entry. Do amounts round to 0 decimal places there as well?


#8

When you edit the Sales Invoice or quote it does show the correct price its when you view or print the item it rounds the numbers.


#9

I double checked and sure enough there is an inconsistency in how the system is determining number of decimals across various screens in the program.

The latest version 14.1.20 is fixing this issue.


#10

Thanks for that.


#11

I’m facing the same problem. All amounts are rounded to zero decimal places. Currently running the latest version on Windows.


#12

If you are running the latest version, then the issue will be different from previous one. Can you post screenshot of what you see as an example? Also, go to Preferences tab and check what country is set under Date/Number format. Some countries don’t use decimal places in their accounting because their currency doesn’t have decimal places - e.g. Japanese Yen.


#13

This is my preference screenshot

This is screenshot for sales invoice


#14

OK, there seems to be an issue with Malaysian date/number format.

I’m planning to rewrite Preferences section so users will be able to define number of decimal digits and other information manually to avoid these kind of issues.

For now, change your date/number format to English (United States). That will fix your issue for now.


#15

Already changed to English (United States). Thanks


#16

I moved a post to a new topic: Round all amounts to zero decimal places