Manager will not launch after installing v21.2.30

you then

  • double click on the ManagerServer.exe and it should leave a command window running
  • browse

It only flashes a command window, but it doesn’t open it. I’ve tried turning off Avast & Firewall, plus Malwarebytes & Spybot, to no avail.

I opened CMD & browsed to the server folder, then ran ManagerServer.exe & got this error:

Failed to create CoreCLR, HRESULT: 0x80004005

Does that give any clues?

do you have another computer you could try Manger on, if so try that. Server version is least demanding

I don’t I’m afraid, but on looking up that error, I came across this:

which seems to relate to SDK. I did install .NETFramework 7.0.5 the other day from an install file including SDK, & I have now uninstalled that & reinstalled just the 7.0.5 runtime version. However, Manager still isn’t working (Desktop or Server). Thanks all for your assistance so far, & if you come up any with more solutions, I will give everything a try.

just go for cloud edition .

Last I heard Manager was not using that series

then I agree with

This user’s experience highlights the risk involved in staying with out of support operating systems.

They will work until they won’t and Murphy’s Law says they will break down just when you need it most

1 Like

I looked at the Cloud version, but it’s too expensive for me - I don’t get paid for my work as it’s all volunteering with charities, & I am a UK pensioner (which says it all!). I have various versions of .NETFramework, including 4.8, so I guess I should not also need 4.6.1? I think I’m right in saying that later versions of NET Framework include earlier versions, so that should be covered? As to upgrading to Win10/11, surely it should not be necessary since Manager includes Win7 in its system requirements. I must admit, I am totally stumped by this!

I’m beginning to suspect that this is a Webview2 issue - can anyone advise what version is being used, please?

See post by Desktop Edition Crashes on Launch - #26 by deeplist

I would also recommend to show screenshots of the error.

I tried this, to no avail - downloaded WebView2 107 (per Deeplist), & reinstalled pre. December 2022 Managers (& the latest version), but the same situation persists. BTW, the Webview2 version I originally had (& uninstalled) when this first occurred was 109 (the last for Win7, I believe).

Sorry eko, there are no screenshots available as I am not getting error messages (except the one above with the Server version via direct cmd input) - Manager simply does absolutely nothing. I see that there are several instances of this problem in the forum, going back several years, so it would be great to know what is happening so the developer can avoid whatever the problem is in future releases.

Any other ideas, anyone? I will also keep trying to find the solution, & post here if I do.

All versions of Manager mostly use shared code

So I would concentrate on getting that working first. After which then try to get desktop version working.

However if you have limited time, use the cloud version for a limited time.
At some time you will need to update your computer. Windows, Mac, and Linux are all supported by Manager.

I tried Win10 ages ago & hated it, & System Restore did not work on the version I had. Furthermore, I HATE that big corporations dictate to end-users & developers alike - it has simply got way out of hand!!! I’d rather go back to Linux, although there are some programs I use which are not supported there either. Besides which, I actually like Win7. Maybe I have to go dual boot again - hey bloody ho!

I’m still trying everything I can think of & getting nowhere, even with the server version sent to me. Would the developer please assist with this as I am distraught & heartbroken that I do not have any working version of this otherwise brilliant software, which I have recommended to several persons.

Fogive me if you have done this already exactly
Download the 64 bit server version (you did say you were running W7 SP1 64 bit) from here and follow the instructions on that page…

You do not open a CMD window first it should do itself when you open the ManagerServer.exe file.
Try a different browser (Firefox/Chrome), there may be issues if you are using Internet Explorer.
I have just tried it on my spare laptop and it runs fine (W7 64bit Manager version, Firefox)

I will try again, but this is what I tried earlier in response to another post & it doesn’t open a CMD window itself which is why I tried manually. Could you please tell me which version of Webview2 you are using?

I haven’t used Internet Explorer in decades! I use Vivaldi Browser, which is Chromium-based. I also have Firefox, but as I say, I did not get that far to open in a browser. I did also have Edge (also Chromium-based), which I hardly ever use, but since this problem arose & I’ve been trying different Webview versions, I uninstalled Edge in case it was conflicting.

UPDATE: Tried again with another Server download, but still not opening CMD - it simply flashes up & disappears. I must have something else installed which is conflicting, so I shall have to uninstall possible culprits, one by one.

That’s what you get if you navigate to the desktop version folder and click on Managerserver.exe there.
You must use the exe file from the server edition from the zip file. It doesn’t matter where you unzip the folder to. I have mine unzipped to my D: drive and run it direct from there.

I don’t have the computer here with me now, but I’m pretty sure the reason I used the server version was it did not require Webview, which was creating too many issues, and it is not installed.
There are some instances where the CMD screen just opens up empty, but I just close it and try again and it always works on the second try…dunno why but no big issue for me.

That is exactly what I have been doing, but it doesn’t open a Command window at all - it’s trying to, but it just flashes for a second & closes immediately!

Sorry but I hope that you are aware that even the Desktop version is browser based. You are advised to at least have the bog-standard Windows 7 Sp1 plus the related browsers installed before installing Manager. This forum is not about your hardware issues but about Manager running on standard installations and you seem to have for whatever reason known to you changed the original OS installs to those you prefer, but as such I would recommend this topic to b e closed because however people may want to help it will just be endless discussions without a solution wasting everyone’s time. This is definitely my last post in this discussion.

Yes, I did understand that Manager Desktop is browser-based, which I think I referred to above, & I am running Win7 SP1, so I don’t understand your comment about changing original OS installs? As far as I am aware, I do not have any hardware issues, & this problem suddenly appeared on 20th April, & I am sorry that you feel I have been wasting your time. Anyway, thank you to everyone here for attempting to help. If I resolve the issue, I will post how I achieved it.

UPDATE: I temporarily gave up on getting Manager to work on this PC for now, & used ManagerServer.exe (evaluation) on a borrowed machine - after having installed security software & got rid of very many viruses & malwares! THANK YOU, THANK YOU, THANK YOU to those of you who directed me to that solution, which I’m minded to save up to buy. It has rescued the day & I have been able to produce all the reports I need for tomorrow’s AGM. I am SO relieved. Thanks to all of you!

FINAL UPDATE - SOLVED: For those who want to know, after a very long & arduous task, I have identified the issue - it was WebView2 version 109 - this was installed by a program I have used for donkey’s years (TrayStatus) which I updated to their latest version (v.4.7.# from 4.6) & which required NETFramework 7 & WebView 109 (the last for Windows 7), which it downloaded & installed by default. I initially thought the problem was NETFramework 7 causing the issue, but I now know for sure it was WebView2 109.

I am delighted to say that I have reverted to WebView2 107 (108 would not install) & TrayStatus 4.6, & all the programs I have used for many years (including Paint.NET) plus ManagerServer & ManagerDesktop are all now working as they should.

It has been a nightmare to identify the culprit, & I hope this notification helps others having similar problems.

1 Like