iOS Mojave Manager 18.11.10

Can’t locate latest business since upgrading to Mojave and despite downloading most recent (according to Manager site) v 18.11.10. Pls advise. Am able to open earlier businesses.

UPDATE I’m not quite sure whether the problem is that I can’t access the current business (I had set up different ones to manage each year until I learned how to use tracking codes) OR that the business that does open had suddenly cut off and deleted / hidden all entries since 30/06/17. Advice would be very welcome as I am supposed to complete this month’s financial statements and email to Members of our not for profit group by tomorrow. Probably some very amateurish mistake!!

It sounds like you may, at some time in the past, moved the data file for the business somewhere besides the default data application folder. There was a time when that practice was considered more acceptable than it is now. During that time, data files could be renamed with plain language titles. That way, your file could be kept in a folder with other things relevant to the not for profit group.

The first thing to do is to use Spotlight to search for files with .manager (the extension) in their names. When you locate that file, it can be restored according to this Guide: https://www.manager.io/guides/8890.

Sorry I didn’t reply earlier. I haven’t ever changed file location to my knowledge. I tried to search for files with .manager in their names but the computer didn’t find them. What I ended up doing - because I had to get the reports done by month’s end - was to go back to a time prior to updating to Mojave. This was successful, although time-consuming, and I was able to do the reports. I want to reinstall Mojave (better security, function etc) but am a bit wary now about Manager. Do you suggest upgrading Manager first, and can you pls give me the url? Going through the Manager website, it seems 18.11.10 is latest, but I’d like to be sure. Or should I update the iOS first? Thanks for your help.

Current version of Manager is 18.11.28 - see here https://www.manager.io/desktop/download/

Don’t know where you get 18.11.10 unless you are sourcing your downloads from a third party site

I’m not sure where you are looking, but all your downloads should come from here: https://www.manager.io/desktop/download/. As of my writing, the latest version is 18.11.28.

It should not make any difference what order you update in: reinstall Mojave or update Manager. I have a bigger concern, though. Two other Mac users have also reported difficulty finding their business data. I’d like to ask you to navigate to your application data folder and post a screen shot of its contents. These files are normally hidden, which is why they don’t show up when doing an ordinary search. The easiest way to see them is to copy the application data path from the Preferences pane and paste it into the window in the Go to Folder function under the Go menu of the Finder. If not using it already, switch the view for that folder to the classic List form so you also show the metadata for the files.

Once I see the contents of that folder, I’ll be able to give further guidance on getting back up and running. Relax, unless you (or someone else) deliberately deleted your data, it’s lurking there somewhere. It sounds like your index file just got corrupted somehow.

Thanks, Tut. I may not be doing exactly what you ask but I can’t see anything that looks like a data path in the Preferences pane of Manager (the one at the top of the page to the right of Users) - see following.

. I’ve looked under Manager in the Applications folder of the computer but don’t see anything there either. Am I doing something wrong?

Your version is so old it will be under About Manager.

But let’s not waste time with obsolete versions of Manager or macOS. Your data is obviously on your computer, or you would not have been able to get your financial statements out. So please do the following, in order:

  1. Make a backup of your business. For this purpose, you can back it up onto a USB flash drive, a remote hard drive, or anywhere else that will be accessible after you update again to Mojave. See this Guide if you have any questions: https://www.manager.io/guides/8890.

  2. Update Manager from https://www.manager.io/desktop/download/. Follow procedures in this Guide: https://www.manager.io/guides/7116.

  3. Update to Mojave.

  4. Launch Manager. If your business is there, you are finished.

  5. If your business is not listed, look under Preferences for your data path. Follow the instructions I gave in Post #5 for navigating to your application data folder. Post a screen shot of the contents of your application data folder. It should look something like this (you may have more or less files with alphanumeric names):

Hello again, Tut. I have reinstalled Mojave and also Manager - now v. 18.11.35. When I open it, again I can only see two older businesses and the most recent one. I’m attaching the contents of application data folder. I do have an external backup of the current business; should I copy it into the application data folder? Thanks as usual for your support.

Sorry, I mean that I CAN’T see the most recent business!

If the backup is recent, go ahead and add it. That’s probably the easiest way to get up and running.

I’m curious what’s in all these folders inside your Manager folder.

Oh, oh! I saved the file I want by saving the entire business direct from the Manager businesses page and it looks quite different from the ones in the folder you directed me to. Its icon is a black square with a green “exec” in top left corner. When I put it with the others and looked again at the businesses page, it doesn’t come up. I’ve tried to double-click on it on the USB and it simply opens another Manager. Sorry to be troublesome…

You can’t save business files from the Businesses page. So I honestly don’t know what you are talking about.

Fortunately, the attempt I made to save from Businesses page was in addition to using Time Machine for the entire hard drive. I have been able to restore the latest files from this to the location that was shown as my path from the home page of Manager, but I still can’t see the latest business using Manager v. 18.11.37 downloaded today. As before, the two earlier businesses are there and intact 37%20pm but Combined Probus Club of Lower Templestowe 2018 on is missing. The following shows that it seems to exist with the others ![02%20pm|690x415](upload://lvTIMT4jWrxDJuaMiv2OoJH5pAS.jpeg Pls advise what I can try next. Thank you.

Sorry, the second image didn’t upload

Screen Shot 2018-11-19 at 5.42.02 pm

  1. I have already asked questions you have not answered. Please show me what is in some of those folders. None of them should be there.

  2. I cannot be certain from what you have shown, but it sounds like you are moving files directly into your application data folder. You should not. The only files in there should be created by Manager or imported using the Add Business button.

  3. It also looks like you might be backing up to your application data folder. Again, you should not. You will lose your backup when you lose the original file.

  4. Your application data folder seems full of files that should not be there. Read the Guide about managing its content.