Impossible to migrate from 16.9.98 to 21.7.28 with 20.9.89 recommendation

Hi, I’ve been running v16.9.98 till yesterday. When I changed computer I lost the possibility to open my database. I saw posts from 2020 where it is suggested to run version 20.9.89 which is supposed to open the file and convert it to SQLlite but it does not work. I tried to run older versions but they are not opening at all saying that I should download a newer version.
Can you please help?
Thank you

Search the forum for how to do this

I appreciate the suggestion but if I ended up trying version 20.9.89 means I found it as the solution suggested by lubos in all the posts I read. since this did not work unfortunately. Or maybe I’m doing something wrong.

Have you followed the process described here Restoring data issue - #2 by Patch

What is actually going wrong / how is it failing?

Hi, I installed v 20.9.89, tried to open the DB and got this message:

You can find the older versions on Github. Just find the version you were using and install it.

That is rather old.
I’m not sure if the sql importer in v20.9.89 can update a version 4 years old at that time.

By the way is it just that business file? Do you have other backups which can be imported by v20.9.89? It is possible for a file to become corrupted and not readable by any version of Manager

That’s a good way to check if the business file is actually corrupted so not readable by any version of Manager

However it appear that archive only goes back to Nov 2019 Releases · Manager-io/Manager.msi · GitHub

You are indeed right. Github doesn’t go that back. Anyway according to thread " Restoring data issue" v20.9.89 is supposed to read v16.x.x databases. Simply it doesn’t on my machine.
Anyway If I try to go earlier with the versions I get a series of errors all different but similar to this:


At the same time I can still open the same DB with the old version on my old computer with v16.x.x which means it is not corrupted.

for completeness of information if I try to import the DB instead of opening it I get this message:

I believe that message mneans that you are trying to open import it with version 20.9.48 and the import file has already been opened with a later version

The messages are from two different versions - 20.9.58 and 20.9.48

I’ve done e number of tests, which include hopping versions. Every time I try with the original DB (which still opens flawlessly with v16.x.x). Funny that I tried installing the oldest version available (v19.11.0) which is not starting at all… I also tried opening from another folder with a shorter path (you never know). I’m running out of tricks.

Write directly to @lubos, the developer. I think that it can help you update the DB