Mac Catalina Compatibility

Hi - I have just updated my OS to Mac 10.15 (Catalina) and now cannot open Manager. “Manager can’t be opened because Apple cannot check it for malicious software. The software needs to be updated. Contact the developer for more information.”

Help!!

Please see

Mac is upgrading the O/S to 64 bit Catalina soon

earlier in this forum.

Catalina apparantly checks all the permissions of the used programs.

The Guide on macOS installations was just updated with a new note about Catalina: https://www.manager.io/guides/7116. But your warning message is one that has not been reported previously, so the recovery may be different. Try the procedures in the Guide anyway (opening twice). It could be that different regional versions of Catalina contain different messages.

Tried it, but did not work.

I have been using Manager off a SD card for years, and it worked even after upgrading to Catalina. However, when I updated Manger to 19.10.15, it stops working. The message is the same as some of our members here. "Apple cannot check it for malicious software. The software needs to be updated. Contact the developer for more information.” Any solution?

Thanks

Install Manager in your Applications folder according to the Guide. Running anything from an SD card is going to be problematic, especially since the program calls data from the application data folder.

Sadly not Tut - I just get the same error message and can’t seem to get past this. Screenshot attached…

Screen Shot 2019-10-15 at 9.09.31 am.png

OK all good now. I followed Reis’s thread and stumbled upon the screen which gave me the warning but also gave me an ‘open’ button - and that let me open it. Unfortunately I can’t recall exactly how I got there - but I think it was from clicking the app in the apps folder in ‘Finder’ rather than the Apps folder in the Dock. Weird - but there does seem to be a way in if you persist!
Thanks for all the tips…
Martin

You were apparently trying to open the downloaded disk image itself. Read the Guide. You open the disk image, then install the program it contains in the Applications folder, then open it from there.

1 Like

No - after reading the guide you posted I moved the disk image to the app folder and tried to open it there with the same result/same error message I posted previously. I tried it a few times with the same result - and then followed the thread that Reis had posted which led me to a different screen which showed an ‘open’ button. Sorry I can’t be more precise in recalling the steps I took - but I was definitely unable to open it from the app folder in my dock…

Of course, I cannot reconstruct what you did either. Two things are clear, though. At some point you tried to launch the disk image from the Applications folder without first mounting it. And later, you mounted it, installed the program bundle correctly, and went through the process Catalina includes for forcing unnotarized software to open.

Because (as you said) you moved the “disk image” to the app folder and still tried running it from the image.

You need to open the image and drag the application itself to the application folder.

I haven’t upgraded to Catalina yet but this sounds familiar with other apps from developers unknown to apple. In the past for other apps I have had to go into System Preferences > General and change Allow apps downloaded from: to App Store and Identified Developers. Then the first time you go to open the app right click it and choose open and a different dialogic box appears where you can allow it.

Not sure if this is the same in Catalina but I would expect it to be a stricter version of the same thing.

The situation is similar to previous versions of macOS, but as you surmised, there is now an additional layer of security. This Guide has recently been revised for Catalina: https://www.manager.io/guides/7116.

I’m running Manager on Catalina (10.15) with no problem.

Just go to your Security & Privacy from your System Preferences, on General Tab lower part there is Allow apps downloaded from: in two radio buttons

  • App Store
  • App Store and Identified developers
    below
    there should be open anyway button, it will allow Manager to run, this is what I do on my MBP and iMac have no issue.

Thanks hope this will help you.

Not in Catalina. Programs must now be notarized by Apple or you must go through a two-step process to vouch for the software yourself. The Guide I linked to two posts above describes that process.

Thanks Meta G. This worked for me. I have just upgraded to Catalina and followed your advice. System preference -> Security & Privacy -> General -> Allow apps downloaded from: to App Store and Identified Developers. then it all flows. Thank you, have an awesome day.

Click on manager with CMD button there will be open option click that. after that you will get warning option with open option also