Internal Error after renaming account

I need help. After editing an item (chart of account) and updating it i am faced with a message showing as under

After I go back to menu (dash board), and if I click any tab other than SUMMARY, this message goes away but if I click on tab SUMMARY, the internal message keeps coming back.

Can anyone help me how to solve this issue.

Thanks in advance

It would help if you say what version of manager you are using and what you actually edited

Thank you Joe.

It is cloud version 20.7.16

I edited an item of chart of account in settings => chart of accounts

Can you undo the edit - it looks like you have a duplicated entry?

What exactly did you edit?

Already tried undo the edit. Still same problem persist.

I changed the name of one inventory adjustment income A/C than already undo the edit.

can you undo it using the new History button

@sonicgroup, what type of account are you editing? Is this an ordinary account you created yourself? Show the Edit screen for that account. I just tried editing the name of an ordinary account in the Income group, and had no problem.

Also, is it possible this was a built-in (automatic) account that you renamed at some point? Show a screen shot of that portion of your chart of accounts.

I can tell you, @lubos will consider this a bug. But knowing more about the circumstances will help identify what is wrong.

Let me explain the things I did before this problem cropped up:

  1. I opened an item in cash account. But later, after posting some entries through inter Accounts Transfer, I deleted the entries.

  2. Then, I did some entry in Inventory write-off, allocating an account. I then edited this allocated account after going to setting => chart of account.

  3. Just after that this problem came up.

  4. Lastly on advise of Joe, I undid every activities of today but this cannot be undone, see picture below:

Lastly, interestingly, I can access all tabs in dash board except SUMMARY. Once i click on summary then I get message of INTERNAL ERROR

I edited the chart of account as encircled in below picture but I have UNDONE the change

Just one more information may be helpful to solve this problem. In history, once I try to undo this entry, I get this message:

How many cash accounts have you setup?

Today, I set up one but later deleted it before thia problem came up

In history, the last remaining entry I want to delete cannot be undone but the message of internal Error crops up as explained above

I suspect that you get that error because when you try to undo the Create, the cash in hand account now has no entries and this throws the error Value cannot be Null

I don’t think this has anything to do with the Summary error - I think that is related to the previous account edits - and maybe the undo did not undo all the way

This confirms me in my opinion that Undo’s are not a great idea in the History tab

@Joe91, I think you have formed an opinion too early. I am sure this problem is not related to UNDO’s. In fact, I think this feature is a great addition.

I just replicated to edit chart of account in an earlier backed-up account, I got same error message. So @Tut is 100% right, undoubtedly, this is a bug. Therefore, I urge @lubos to take care of this problem at the earliest.

On cue from @Joe91, I did further test-run of history feature. As i mentioned in my earlier post that an edit as below could not be UNDONE

I tried to delete again just to make sure about @Joe suspicion

and now have evidence to support Joe’s suspcion. The undone entry when I try to UNDO again, it shows below internal error message

So, I draw attention of @lubos to above findings and let us have his comments.

To my opinion, this issue definitely needs attention on priority basis.

Undo is a widely recognised and valuable feature in most main stream software.

What is being developed for manager is more advanced again, supporting out of order reversing an earlier action. It would be a valuable feature but will need provisions for the database integrity protection built into other areas of Manager (accounts not empty when trying to delete). I assume this is going to take some time to develop.

@Patch Yes, I agree that it is a great feature but certainly not without certain drawbacks as is noticed in my case. May be need more time & efforts for perfection by LUBOS. In the meantime, how to rectify the Internal Error display problem when Summary tab is pressed. I can’t see any of summary items. It means I am stuck and cannot use the software until this error is corrected

The latest version (20.7.21) is fixing the issue with history undo. Is your Summary screen resolved too or still an issue?