DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Error message when importing bank statements


#1

Error message when importing bank statements

bank transactions>
New bank transaction>
import bank statement>
select bank account> I selected bank account 1
select file from your computer> I browsed to / selected files several times. I tried *.qbo and *.qfx files from 2 different banks. The error message (see below) was the same on all attempts.

Length cannot be less than zero. Parameter name: length

running Linux Mint 18.3 Cinnamon 64 bit
Linux kernel 4.13.0-32 generic
results were the same in Firefox and Opera browsers.


#2

Have you opened the *.qbo and *.qfx files in a spreadsheet or text editor programme to verify that the data contained within is correct ?


#3

Account data is accurate. I assume that the “100” in the first line is the “length” that manager wants.

OFXHEADER:100
DATA:OFXSGML
VERSION:102
SECURITY:NONE
ENCODING:USASCII
CHARSET:1252
COMPRESSION:NONE
OLDFILEUID:NONE
NEWFILEUID:NONE

0 INFO 20180211051239.000[0:UTC] ENG 20180211051239.000[0:UTC] Bank of America 11162 11162 ssiowen 0 0 INFO USD 111000025

#4

I only use *.qif files, below is a sample, and it doesn’t contain any data like you are showing.
0000000%20Bug%203


#5

I can get qif from one bank.
As I seem to be the only one having this problem,
I am looking for my MacBook that I use for business
travel. If it works OK on that, I will change my Linux
computers back to the last kernel before a recent
update. That updated kernel may be the problem. I
will update when I get that done. Thanks for your help,
and thanks for providing Manager. It’s really great.


#6

I have the same problem here importing .ofx files. It’s a new problem. Some Manager versions ago it was working fine.

Length cannot be less than zero. Parameter name: length

Windows 10


#7

I am having the same problem, but using Windows 8 and trying to import a .csv. I imported an entire year’s worth of transactions for a credit card account yesterday in the .csv format, but now Manager won’t allow me to do the same for a regular bank account. I too get the “Length cannot be less than zero. Parameter name: length” message. What could have changed? Anyone able to help?


#8

Open both .csv files and see if they are both consistent in format.
I recall one user had the amount column left justified whereas it should have been right justified.


#9

Hello.
I have the same issue here. with .qbo and .qfx files.
windows 10, and the latest version of manager.
I only noticed this after an update but only do the import once a month or so so not sure if it’s related.
I can’t import the statement anymore so not sure what to do. I really don’t want to do it manually.
Thoughts?


#10

Thank you Brucanna. To you and nktech1135, I discovered another forum session where my questions were answered! It was from back in 2014, and the questionto enter into the search line is “Importing bank statements .csv template?” It has a lot of info and helped me import an entire year of .csv transactions successfully. My issue could have been two-fold, not sure because I changed two format issues in my data file. One was the date (I was using x/xx/xxxx instead of xx/xx/xxxx- who knew!?) and the other was the format of my currency (I changed my negative numbers from using parentheses to a negetive symbol preceding the numbers). But thanks for the reply and good luck nktech1135!


#11

It was probably both issues. Imports are very specific.


#12

As I am learning! I’m also learning that you have to formulate
the correct question when you search for help on the Forum. It
took me a few tries, but I finally found the help I needed. Thank
you!


#13

Hello.
I still think my issue is a manager bug.
I tried importing a file that worked a month ago before i updated to any 2018 version and it is failing as well with the same error as the others.
This was a .qbo file which is what i’d prefer.

Thoughts?


#14

You need to provide specific details beyond saying you could not import the statement. What happened? Post a screen shot of any error message.


#15

I thought i made this clear in my origional post on this thread. My problem is exactly the same as the origional poster.
I don’t think his issue was resolved?


#16

I have the same problem. I cannot import QFX or CSV from my checking account. I can import QFX from my credit card account. On looking at the CSV version, it appears that when there are multiple checks in the statement where the last field is empty, it fails to import. If I limit the QFX download to one (day) that the CSV shows that the last field is filled in, then the import works. Therefore I assume, the zero length notification is associated with the fact that if the checks (in my case) do not have a number in the last field, then Manager thinks it is an error and will not import the statement.


#17

is what shows after QFX attempted inport


#18

The original poster, @owen, never said whether his or her problem was resolved, only that suggestions would be checked. When someone vanishes after receiving suggestions, the usual presumption is that the problem was resolved. So, by saying that you have exactly the same issue, you are implying your issue could be resolved in the same fashion.

Further, referring back to posts weeks or months old does not help you get the best answers. You very likely have a different operating system, edition, or version. Your preferences may be different. The program has definitely progressed since then.

Without more specific information, all anyone can tell you is that imports are particularly tricky because different banks format exported files differently, even when using the same file type. Many of the standards include options, and many banks don’t implement them properly.


#19

So I am using Windows 10.
i was using Manager version 18.1.72 which failed and was what the above information was based on.
I have upgraded Manager to version 18.3.4 (desktop version). and attempted to import the files which failed.
I have also run a test of 2017 QFX files into a new company (on version 18.3.4) so everything should have been clean and this file did import on a last years version of manager (i think it was version 17.12.64). It failed to import.
Also, as a check on the QFX files, I imported them into quicken 2016. They imported correctly into quicken.
What Information can I give you or do you want to start a new thread?


#20

Hello.
OK, i did a little more testing on this.
I downgraded to the final version of manager 17 and tried the imports on a test business.
They worked as expected. Next i upgraded to the current version and tried the imports again. I got the same error that was posted in this thread multiple times already.
If this doesn’t convince people it’s a current version bug i’m not sure what will. The only differences were the version of manager itself and the business. I had to create a new business in manager for the downgraded version because i don’t know how to downgrade a business and manager will not run it without doing so.
@lubos, are you watching this? I’d be interested in your response to this.