Email problem after upgrade

The issue with Manager not sending email has been fixed in latest version.

I finally managed to successfully do a new install of Manager Server to version 20.9.89. I opened with ufw ports 25 and 587 among others but the email test times out on both ports. It used to work on port 25 with the previous Server edition that worked with mono. I contacted my ISP but as credentials work on their server they advised to seek support here. Thank you in advance.

See the Guide: Troubleshoot email issues | Manager. Visit all relevant links. If you cannot resolve your problem, provide all information requested in the Guide.

@Tut I have used this and all worked well until the recent upgrade to Manager Server version 20.9.89 Please try yourself with the new Server version as it no longer works, thank you. As mentioned all ports are enabled.
MANAGER-SERVER version 20.9.89
OS: Ubuntu 20.04
Email credentials as working on email account. Tried ports 25 and 587 both gave time out errors when testing.
All relevant SMTP and IMAP ports enabled in ufw

No one else can try your email. You have obscured your SMTP server hostname, so no one can even determine whether your settings look credible.

I followed he instruction “… A screen shot of your Email Settings page (Obscure only personal information. The more information you show, the easier it will be to obtain help.)…” As the servername is the same as mail.domainname.com I would disclose the personal information that I should not.
As mentioned the email server works well and also worked well with these settings before the Manager Server upgrade.

I cannot see why you consider a domain name to be personal information. But that is your decision.

I agree! However, I follow your instructions and this would disclose email accounts@domain.com. So please highlght for me what other personal information I should blank out as this is the only personal info one could obtain. I also do not see what you could digest from the mailserver info without the account info. Can you please confirm that you tested it yourself with your own Manager-Server installation to ensure that I am not hallucinating that this is a bug introduced with the new version.

Out of curiousity I also trialled the desktop version. The ones before the non Nano version works and version 20.9.3 doesn’t (OSX Catalina)

@eko, there is no requirement to obscure anything. The purpose of the instruction is to allow users to obscure such things as a personal email address to which they are sending copies. Since you are sending your customers and suppliers emails, there seems to be no reason to obscure the domain from which those emails will come.

As I already told you, no one can test your email settings except you.

I don’t know what you are referring to as the “non Nano version.” And I do not understand what v20.9.3 has to do with anything. Are you referring to Mono? If so, Manager was still using Mono in v20.9.3. That changed at v20.9.66.

Sorry I meant Mono. The older Desktop version works and the latest v20.9.89 also does not.

Highly likely a firewall issue.

To troubleshoot,

  1. confirm that you only use ubuntu firewall and your router is open for outgoing traffic;
  2. confirm that you allowed default rule for all outgoing traffic/port? or specifically;
    sudo ufw allow out to any port 587
  3. output ufw status rules here for information;
    sudo ufw status verbose

timeout suggests that ports are being blocked.

Thanks but I already opened these ports in ufw and many more such s the IMAP and POP ports. ufw status confirms the allow on these ports. As it also happens on my OSX- Catalina computer with Manager desktop version v20.9.89 and with firewall and antivirus disabled and the Manager Server v20.9.89 on Ubuntu 20.04, while both worked well before the non Mono versions it would be useful to know 1) do others have same issues since upgrade and 2) if so did they resolve it.

I am asking the questions to troubleshoot because email function works for me on the latest version.

There is no way to know unless they post on the forum. I can only tell you that email timeout or log-on problems have been reported irregularly once or twice per month for years. They have almost always turned out to be user setup problems, even when someone thinks they have changed nothing in a working setup. Often, they are the result of ever-tightening security measures by email providers—sometimes in the face of denials of any changes by the providers, while their web sites reveal exactly the opposite.

Your report of difficult is the only one since the switch to .net Core and deprecation of Mono a few weeks ago. So the rate of reported problems has not increased. If this was a Manager issue, many more of the thousands and thousands of users would be complaining.

Meanwhile, if you were willing to share your provider’s identity, someone might have useful advice.

So not a fool after all and hope it gets fixed for all those on Ubuntu Servers see: lubos

9h

I’m going to mark this as a bug for now because it could have something to do with transition to .NET Core recently.

@eko, your problem is not likely to be related. The other user received a specific error message that you did not.

Well let’s see what @Lubos discovers. I presented a timed out error message. I made also very clear that things work everywhere even with other applications of the same server. Another user’s server where I did leave my credentials showed the same problem. I am not sure why you just defend the status quo rather than trying to find a solution. You are very capable and responsive to many request but that does not mean that you know it all and sometimes we depend on @Lubos to fix things. Only when he has released a fix for the other user’s error related to the switch to .NET Core from Mono will we be able to judge if this was a bug after all. Keep up the good work, but when you do not know I would recommend to wait for the resolution, no-one is perfect including me and if I am the one making the mistake I have no problem apologizing for it.

Well, there’s still more info required if you want us to help debug your problem.

I understand what you’re saying in relation to getting help, it’s often difficult, but that because mods see the same questions again and again, Or users don’t provide enough information, or some other unknown consideration.

For example, you indicated a timed out error, but how else have you tested those credentials and not received the same error?

More important questions for me (if you’d like my help):

  • from what version did you upgrade? This will help ascertain if it’s a mono issue or not
  • where else have you tested the credentials that are in manager server and do they work from other software on the same server?
  • you did obfuscate your domain name, that’s not too relevant, but also the mx server, what / who is your email provider? Is it gmail, Microsoft, self hosted? Is it from your own server itself? What? Often issues are beyond manager scope and without knowing who your email provider is, we can’t provide that sort of nuanced assistance that will be required (eg, App Level passwords for google/gmail, TLS issues with outlook, etc)
  • what network analysis have you conducted from the server that runs your manager server? Have you run an nslookup or done a telnet from it and checked your credentials that way?
  • try some packet captures of your network, and analyse the data between your manager (os) server and your host provider

The “timed out” error from manager is at the highest layer and there are many layers below manager that can let you down.

* eg, your credentials may work from your desktop PC, but not from the server running your manager server, and this can be for many reasons, also, email credentials don’t necessarily work within manager (as is a common problem with gmail and outlook specifically).

Hence, you need to help us to help you. Provide as much information as you can and include all diagnostics you have run yourself.

Also you’re saying “the older desktop version works but the newer server version doesn’t”. You’re comparing apples and oranges.

To nut that out further, compare old desktop to new desktop (and please provide version numbers), but since you’re focused on server version, what was the last server version you had it working on?

Sorry, I only refer to the server versions installed on Ubuntu 20.04. I used to update every day but not check email functionality every day. So the actual version numbers you ask for can not be established. I only tested on Ubuntu servers, but indifferent locations. The email servers are hosted with Chemicloud and when contacting them as normal access via email works is not perceived as an issue on their end. One of the VPS on which Manager server is installed is with Contabo, Their helpdesk also refers to the Manager Application. One of the things we all know is that this my be related to TLS and he difference between Mono and Core in handling this. Hence no longer bothering until a version that solves this for other user is released by @Lubos. Thank you for the willingness to help but it boils down to problem only after Manager update. No changes in server settings anywhere. So let’s wait.

No worries, but without any further diagnostic information, it’s going to be pretty hard to solve it for you. Even Lubos can’t really help unless he knows more about your setup. Anyway, good luck. I hope you get it sorted.