Editing text fields causes cursor jump to end of line

I’m experiencing a small annoying problem when I edit a text field (somewhere in the middle of the text) the text cursor (or insertion marker) jumps to the end of line every time I type a character. Say I want to insert and type in a word in the middle of the sentence, the cursor jumps to the end of the text every time I type a character.

I can see this happen when I edit a sales invoice and edit the text fields for each sales item. Can anyone replicate this?

Desktop App v19.7.41, Windows 7

i checked and found no such issues.
19.7.41 Desktop edition
Windows 10 x64

I am also having this issue.
The problem is in the 'Description" field, not the main description but the description for each item where it displays “Account”, “Description”, “Qty”… If I have text already in the “Description” field and then want to edit a word in the middle of the sentence, the cursor skips to the end of the sentence after I type the first letter so lets say I want to edit a Sales Invoice and have the following sentence already in the description: “Amount before discount” and then if I want to edit the description and change the word “before” to “after”, so I select the word “before” and type “a” the word “before” is replaced by “a” but then the cursor skips to the end of the sentence which is where the rest of my word “fter” appears so it ends up looking like this: “Amount a discountfter” instead of “Amount after discount”. This happens in every “Description:” field on all tabs: “Receipts & Payments”, “Sales Quotes”, “Sales Invoice”, “Purchase Invoice” …

Desktop App v19.7.41, Windows 7

This does not happen on a Mac with v19.7.41. This could be another in a recent series of Windows-specific problems. If so, it appears to be limited to Windows 7 so far.

After reading Tut’s post, I decided to run windows update and noticed there were some new updates to download so I installed them, restarted my computer, then tried to edit a sales invoice description field but I still have the same problem :frowning: !

So did you just update Windows 7, or did you upgrade to Windows 10?

I don’t have this issue on any of my computers. Windows Vista, Windows 10, and Windows 8.1. All running 19.7.41 desktop.
My default browser is Firefox. As this is a browser based interface it could be a browser issue?

The problem persists after a Windows 7 update not upgrade. It must be Windows 7 related since VACUUMDOG tested it on all other Windows operating systems and didn’t see any issue. It’s just strange because it only started doing this since the last update or two of Manager software. I’ve been using Manager software for a very long time now and never had this issue.

Windows updates had no effect. I seen this regression as soon as I upgraded to the v19.7.41 desktop.

@2.71828, I have the same question for you I asked @chrissyzmissy. Did you only update Windows 7, or did you upgrade to Windows 10?

So far, no one has said explicitly that they have experienced this problem with any operating system except Windows 7.

I’m still on Windows 7. Windows updates are routinely applied.

So, as far as has been reported, this behavior is observed only on a 10-year old operating system, and not on more current operating systems. Remember, updates are most frequently security patches rather than functional enhancements. Eventually, your system will suffer from growing incompatibility with other software in the Manager library, even if it remains compatible with the main application.

Yup I’m fully aware of Windows 7 end of life date, and so forth. I don’t see how that is relevant to text fields suddenly becoming buggy in an application.

It is relevant because you say it is happening, and the only common factor among those who report this problem (so far) is their aging operating systems. No one with newer or different operating systems can reproduce the problem.

Whether the OS is aging is moot for two reasons:

First, the download page says Win 7 SP1 is officially supported. If that claim is being made, then one should expect that claim to be honoured.

Second, the regression happened as soon as I updated Manager to version 19.7.41. Clearly, something has changed in the newer versions, which caused the text fields to play up on Win 7. It maybe an OS issue. Or maybe it’s a pre-existing issue in the app that is exasperated by a specific OS version. We don’t know until it is actually investigated. If someone can provide me a link to older releases for Manager, I’m happy to try each version and narrow down which version introduced the bug.

Have you tried using a different browser?
I agree that it is weird to just start after that update, there may have been a small change in code that is causing the issue with a particular browser.
If you google search “cursor jumps to end of line” it may help.
Oh, and BTW, it works fine on my even more outdated OS (Vista) so the age of the OS is not relevant.

I’m using the actual desktop client (ManagerDesktop.exe). Would a browser make a difference here?

Only know if you try it.Click on a Manager link on choose open in new window

@Patch’s advice will still open it in your default browser. The whole program is browser based.
Right click on any edit invoice in the program and copy the link location/save shortcut. Then open a different browser to your default browser and paste and go.
See if the problem is still there. If not, then it’s your browser.

Manager uses internet explorer on Windows.
Open new window opens the the Users default browser and shows the address bar. Additional browser can be tested by copying the address or as described by vaccumdog