Discounts not displayed when copying sales documents to purchase documents

When a sales quote, sales order, or sales invoice with a discount is copied to a purchase order or purchase invoice, the discount does not show on the resulting entry form. But the completed document, when created, has the discount from the source sales document.

You might debate whether a discount from a sales document should ever be carried forward to a purchase order or purchase invoice, but if it is, the entry screen should definitely show it.

In both the purchase order and purchase invoice cases, if the Discount box is checked, no discount shows on the entry form, yet the discounts appear on the completed documents. If the box is checked and then unchecked before the transaction is created, the discount is cleared and does not show on the completed document.

Fixed in the latest version (17.12.69)

How to enable discount % option in new sale invoice i want this option should always appear in the amount field like the older version hope you understand my question.

read this guide

Thanks for reply but i don’t want to check every time that discount box i need this option to be enable always because i need only discount option if there is any solution please let me know.

at present there is no option in Manager to set Discount enabled by default.

but in the previous versions that was always enabled .

anyway thanks for your feedback .

I believe you are mistaken. I’ve been using Manager for 5 years and discounts have never been set by default. Long ago, the discount field was set up as a column on forms. But there was only one option: percentage discounts. Users demanded the option of a fixed discount amount, which required different implementation.