Date bug on both transaction forms and reports


A batch of cash payments about a year was not posted.

When I enter the transaction now it will not accept the original date but only shows the currect date.

When I try to clone a historical transaction it will not change the date but will accept all of the new information ( except for the date) which remains at the date of the transaction I am cloning.

I have never had a problem like this before.


An Update

This date issue is affected all of my businesses.

For example when I create a new Profit and Loss Report…No matter what dates I enter the report appears as current date to current date.

Is this just my PC ? Crazy virus ?

Post some screen shots to illustrate this problem.

I can replicate the problem. Here is the screen for creating a Profit and Loss report in the Northwind company:

And here is the report it creates:

The problem also occurs with the Balance Sheet

I am using Windows 10, Manager Desktop version 17.6.83

This seems to be a bug.


Thanks dcvest

I thought it was just me

Lubos will sort it if it is a bug but it the meantime I cannot enter transactions into any of my client businesses.


I think that @Brucanna also uses Windows 10. If he can reproduce it, he will elevate it to a bug and bring it to the attention of @lubos.

Can you try the latest version (17.6.86) if the issue still persists?

@lubos, I tried it with version 17.6.87, and the bug is still there:

And in this Profit an Loss report, Manager reversed the dates:

I can duplicate the balance sheet problem in version 17.6.87. Pre-existing reports look OK. But on a new report, no matter what date you enter, today’s date is substituted and shows on the report.

On the P&L, again, previously existing reports are OK. But new reports show as being from today until today no matter what dates are entered. I cannot duplicate the reversal of dates @dcVest claims to have seen. In fact, the input for that P&L with supposedly reversed dates wasn’t shown. Can you verify that what you wrote really happened, @dcVest?

Regardless, there is still at least one problem with report dates. It happens with other reports, too, such as Trial Balance.

Glad you checked so that we know that this is happening on Mac also.

The reversed date happened when I edited an existing report rather than create a new one:


By editing an existing report it is possible to get a report with dates other than today’s, but in this case Manager picks a day close to what was requested and not what was entered:


As the second set of screenshots shows, I did try changing the date format under preferences, but that did not resolve the problem.

I also tried switching to Cash basis but that did not resolve the issue.

@DanCarlin first noticed the problem when trying to enter historic transactions, so the problem seems to be more widespread than just Reports.

Could you please check whether this issue is still present in the latest version (17.6.91)?

@lubos the problem is partially resolved.

Clicking a date in the pop-up calendar will produce a report with the correct dates.

But typing in the dates in the date field (Date in Balance Sheet, and From / To in Profit and Loss) still produces the error.

1 Like

What do you mean like this? What error do you get? Can you demonstrate? Just to make sure, when typing the date, you need to type it properly in your chosen date format.

Sorry @lubos that I explained my problem poorly. Here is what I discovered:

After a date is typed into a Date field, the user must press the Enter key on the keyboard so that Manager accepts the new date.

What I was doing was hitting the Tab key to move out of the Date field and on to the next field. It seems to me that until recently Tabbing worked, but my recollection may be wrong. I now know to hit the enter key so all is good!


I have a problem with dates too and I have updated Manager to see if this errors will go away but they’re still there. The problem I’m having is that I put the correct date in any transaction, let’s say in a spend or deposit, I created the transaction and when I come back to the same transaction, the dates are in the day before I put them. For example, if I do a Spend Money transaction indicating 7/08/2017 and then hit “create”. Then seems to be the same in the summary of transactions but when I open again this same transaction the date will say 7/07/2017. Here’s a screenshot.

The same occurs in reports, lock date and basically, all system. I tried it in Ubuntu and Windows 10 and I got the same error. I’m on 17.6.95 version.

@sulfuror, would you try entering the date in a transaction using only the pop-up calendar. Does that work?

@dcVest I use the pop-up calendar almost every time because I enter my transactions daily.

@lubos, I can duplicate all the problems described, and more in v17.6.95. Dates entered appear in the Edit and View screens as being earlier. Sometimes the earlier dates disagree between Edit and View screens. Corrections revert to the previous errors. The problems arise on both transaction forms and all reports I’ve tried. Essentially, it has become impossible to enter a reliable date.

I’m changing this back to Bugs status. I’ve edited the title to better describe the problem.

In case it helps, I still had version 17.6.26 on another machine, and entering dates worked correctly on that version. So the problem arose sometime after that version.

(And a follow-up on an earlier reply (#15): Using the tab key to move in and out of the date field on forms or reports works in the earlier version.)